0

I have a Lenovo laptop T470, on Windows 10, connected to a monitor (or projector) via USB 3 to VGA adapter that gets either of the 2nd displays stuck at 640x480 ('640 x 480', in case someone is search for this) resolution when the laptop wakes from sleep, any ideas how to fix it?

Some context

  1. It is not the adapter because when the machine restarts the 2nd display will go to a proper resolution of 1920 x 1080
  2. The adapter I am using is a replacement adapter that was working.
  3. The monitor works because I can use a HDMI cable which give the correct resolution on the 2nd displays [You may ask why not use HDMI all the time, in and out of conference rooms at work for meetings and not all of them have HTML, they all have VGA :/ ]

So, I don't want to have to restart every time and was wondering if there is a settings panel I can go to and restart just a process?

Thanks for any help!

0

The T470, T480, T570 and T580 all seem to have issues with additional displays and sleep mode.
(DisplayPort and HDMI attached monitors may show the same behavior.)
Similar issues have also been observed with HP zBook 15 and 17 and the Fujitsu Celsius H760, H770 and H780.
It seems more related to the Intel HD graphics in these laptops than to the brand of the laptop.

The displays go to 640x480 or they go completely dark if the monitor doesn't support that resolution. (Many newer, especially 4K models, want 1024x768 or 1600x900 as a minimum resolution.)

We've got lot's of these laptops at the office and found the following:

  • If possible update the BIOS and/or the motherboard firmware. Newer firmware is far less problematic. Don't forget to update the display-drivers too.
  • Make sure the power-saving mode is set to "High Performance". I know that will drain the battery quicker, but we see the problem almost never in that mode. With power-savings set to "balanced" or "maximum power-save" it happens all the time. (Please note: Windows defaults to Balanced and, after installing WindowsUpdates Microsoft has the nasty habit of switching back to Balanced, regardless of what was previously selected.)
  • In case of a laptop with hybrid graphics (NVidia + Intel HD graphics) disable the "Hybrid" or "Auto" mode in the Bios and set it to "Discrete". That will greatly improve the issue, if not remove it altogether.
    Again: May decrease battery-life a bit.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.