0

I am trying to run ubuntu 16LTS 64-bit on my computer but I come across some problems.

When I try to create a new virtual machine, I only get the option for 32-bit operating systems. All information I could find is that I need to enable vt-x and disable hyper-v. I did those two things, but the problem has not been resolved.

I run on an i7-6700k with ASUS PRIME Z270-P I have never updated the bios, but it has the vt-x option, so I prefer not to update it to not break my PC.

What else could cause this problem?

Thanks in advance

  • Check in the BIOS if both VT-d VT-x are enabled. – harrymc Mar 8 at 18:11
  • @harrymc That was the solution. VT-x != VT-d. Thanks! – Mark Mar 8 at 18:29
  • Possible duplicate of VirtualBox only allowing 32 bit OS – Ramhound Mar 8 at 18:43
  • Good that this is solved, so I added an answer below. – harrymc Mar 8 at 18:59
0

Check in the BIOS to see if both VT-d VT-x are enabled

Both are required for VirtualBox to permit 64-bit VMs, and they are not the same thing.

The full names by Intel are:

  • Intel® Virtualization Technology for Directed I/O (VT-d)
  • Intel® VT-x with Extended Page Tables (EPT)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.