0

I am using an Apple Mac Mini OS is 10.13.6. My default browser is Firefox 65.0.1. I also have the Opera browser installed in the Applications folder.

When ever I drag a URL to the Desktop the Icon shows as a white Icon with a red "O". When I right click on the Icon and go to Get Information the URL has .WEBLOC and the Change is greyed out. I am aware that the .WEBLOC is the result of Safari being installed and integrated into the OS by Apple, but why am I not getting a Firefox Icon (which is the default) on the Desktop instead of the Opera Icon?

I have checked & confirmed that Firefox is set as the default browser in both the OS System Preferences as well as in FF Preferences.

migrated from webapps.stackexchange.com Mar 9 at 0:07

This question came from our site for power users of web applications.

  • I think you should ask this question in apple.stackexchange.com as this question is more about why OSX works or doesn't work in a certain way. Also, Firefox is a web browser, not a web app. If you need a quick and dirty workaround you could always use Applescript until you have a solution. macscripter.net/viewtopic.php?id=21304. – user136952 Mar 7 at 5:32
  • Ok, thank you, I was looking for an appreciate place - did not find Apply Exchange listed anywhere, – SH Queens Mar 7 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.