2

Gmail saves pdfs to default download location despite the fact that I asked it to ask me where to download every time.

When I click "download", I expect a "save as" dialogue box to pop up and allow me to choose where to save the pdf. However gmail instead just saves the file to God only knows where and then opens it with the system pdf viewer.

Excuse me? Why the hell is it doing this when I've ticked the "Always ask where to save downloads" setting? How do I fix this obnoxious behaviour?

I am using google chrome

1
  • Found the answer here: superuser.com/a/1313099/893881 Right-click the attachment inside the email and open in new tab. Then you can choose the download location from the new tab. – Jake Reece Oct 5 '20 at 2:23
0

I also had this problem on my work Google account and not on my personal Google account, so I compared them and found out what the problem was.

Go to Settings --> Advanced --> Downloads, (where you were, and where the "Ask where to save each file" option is already checked.)

Below this checkbox/slidebox there is an option that says something like "automatically open files after downloading". Uncheck this option. It should disappear.

Problem should be solved.

-1

Put chrome://settings/content/pdfDocuments into Chrome's address bar, then turn on the option Download PDF files instead of automatically opening them in Chrome

enter image description here

1
  • Did not solve the described problem – TheIronKnuckle Mar 11 '19 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.