1

When I open a CSV files in Excel 2019 the file is not being parsed correctly. When I opened the same files in Excel 2016 they would be parsed correctly, with the commas used as delimiters. But I have just installed Excel 2019 and it is opening files without recognizing that they are CSV.

I am not trying to import data from a CSV file I opening it directly. This always worked just fine. And I thought that 2019 would be better with CSVs.

Here's an example file samplecsvs.s3.amazonaws.com/Sacramentorealestatetransactions.csv

How can I tell excel that a CSV file is a CSV file?!?! Is there an option somewhere? I don't want to use the "import data" option, it should work automatically.

enter image description here

1

Check your system separator in Excel > File > Options > Advanced and make sure that Decimal and thousands separators are set correctly (., resp. ,).

1

Seems related to this:

Problem:

*.csv files (comma-separated) used to open as tables in Excel (automatically) but then started opening just as plain text, not tables. (and now Excel expect semicolon instead of commas -- then opens as table.)

Perhaps relates for many Excel versions, but for me seems this happened after recent upgrade of Excel in Office365 on OSX - to Excel 16.31 19111002

Debug:

On Windows there is explicit "List separator" setting in the Region / Language: https://stackoverflow.com/questions/17953679/how-to-correctly-display-csv-files-within-excel-2013/37021203#37021203

but this one seems hidden somewhere in MacOS / OSX (i.e. there is not explicit "List separator" setting (or some similar parameter)). This seems to be set in OSX when you're changing your REGION / COUNTRY. (Apparently Excel expects that in German-speaking countries people use semi-colon instead of comma in *.CSV files: http://forum.provue.com/t/using-semicolons-instead-of-commas-in-european-format-csv-files/2780/11)

It does not help to just changing settings like "Number separators - Grouping / Decimal" settings in System Preferences > Language & Region > Advanced ..

HELPED:

Changed Region to UK/US, but then tweaked all settings back to normal:
1. System Preferences > Language & Region > set to "UK" (or US)
2. Customize System Preferences > Language & Region > Advanced.. -- changing there Number / Decimal / Currency / Measurement units to the ones you have in your real country.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.