12

Even if you disable Chrome's automatic sign-in in the browser's settings:

enter image description here

Google seems to follow you when a website offers Login with Google: enter image description here

Is there a way to disable Login with Google at all for external websites?

  • 1
    There really should be. If you log out of your google account (e.g, after done with gmail, click in top right and choose sign out), it will go away. But it is absurd that you are constantly one accidental tap/click away from disclosing your name and email to a random site and having an account created with them. I ended up with an ebay account for my work email the other day.... grrr... – aggieNick02 May 21 '19 at 13:53
  • 6
7

This feature is called one-tap. Its documentation seems to be gone from the website, but StackOverflow has some points. The script in charge is https://smartlock.google.com/client. If you have an adblock extension or something like Greasemonkey, you can block it.

If you want to get rid of the button too, you can block https://apis.google.com/js/platform.js.

-1

Not really sure if this is what you're referring, but I have had similar issues with inconsistencies when signing to sites with Google account, so I disabled the cookie jar/browser consistency.

I reckon perhaps this has to do with a flag in Chrome's settings - #account-consistency

Do the following to resolve:

  • Load chrome://flags/#account-consistency in the browser's address bar. Google Chrome should display the flag Identity consistency between browser and cookie jar at the top.

  • Set the flag to disabled with a click on the menu and selecting disabled from the context menu.

  • Restart the Chrome browser.

Acknowledgements

Martin Brinkmann: Disable the sign-out link between Chrome, Gmail and other Google services

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.