I recently updated JetBrains WebStorm and I find myself unable to debug Node.JS scripts, debugging using Chrome seems to work fine, React-Native debugging works, but when I try to debug a Node script such as the following:

console.log("hello world");

where a breakpoint is set on the first line, the debugger never starts and returns the following message in the console:

C:\Program Files\nodejs\node.exe: Schneider\AppData\Local\Temp\debugConnector.183.5912.23.js is not supported in NODE_OPTIONS

It may be noteworthy to mention 2 things:

a) My username (Windows) contains a space,

b) I accidentally deleted the C:\Users\Jacob Schneider\.WebStorm2018.3 folder located in my home directory.

I've looked, even on the official bug list, but it doesn't seem to be known of, there isn't even a setting for it. Does anyone know how I can return the Node.JS debugging functionality?

Thank you.


Recreated, logged as WEB-37804. Please follow this ticket for updates.

As a workaround, please try disabling js.debugger.use.node.options key in Registry:

  • in Help | Find action, type Registry to locate it
  • in Registry, find js.debugger.use.node.options key, clear the checkbox next to it

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.