1

I have a question regarding USB hubs. I have purchased a hub that goes into the 5.25 inch slot on the front of the PC case and connects to the internal USB3 header on the motherboard. The PC case originally had 2 USB ports on the front, that were connected to the internal USB3 header. I have disconnected those and connected the newly bought hub to that header.

However the USB3.1 ports on the new hub dont work, when I plug in a flash drive, nothing happens, Windows doesnt seem to notice the drive has been plugged in. When I reconnected the old USB3 ports, they worked still, so I think that should rule out the possibility of damaging the internal header when I was removing the cables/connectors.

I have tried the hub in a different (newer) PC and there the USB3 ports on the hub worked correctly.

Despite the title question, Im not entirely certain which USB version is supported on the older motherboard, as I couldnt find a proper spec sheet.

The PC is HP Elite 7300 MT, running Windows 7, CPU i7 2600, 16GB RAM, GPU GT 545.

The motherboard model is (according to CPU-Z):

Pegatron Corporation 2AB5

Best spec sheets I could find are here:

http://www.findlaptopdriver.com/pegatron-2ab5-motherboard-corporation-specs/

(this site worked yesterday (15. march) but seems to be down today)

UPDATE: the site came back on, so Im adding a screengrab in case it goes down again. Pegatron 2AB5 specs

https://support.hp.com/hk-en/document/c02668523

UPDATE: this HP site probably is not the exactly same model and should be disregarded

The USB hub in question is Akasa AK-HC-11BK, specs here:

http://www.akasa.com.tw/update.php?tpl=product/product.detail.tpl&no=181&type=Card%20Reader/Hub&type_sub=USB%20Hub&model=AK-HC-11BK

And the other motherboard (where the hub works) is Asus B85M-G, specs here:

https://www.asus.com/Motherboards/B85MG/specifications/

Could it be because the newer PC has support for USB3.1 and the older one doesnt? So could it be that a motherboard that only supports USB 3.0 doesnt work with USB3.1 hub ? But shouldnt the hub just operate at 3.0 speeds in that case?

When searching on the internet, I have only found the opposite situation, people asking if USB 3.0 hub will work with 3.1 motherboard.

UPDATE 2: The original USB ports on the front panel are blue and have the SS USB symbol next to them. I have tested copying a 2.5GB file from a USB flash drive (Kingston Data Traveler 3.0 32GB, https://www.kingston.com/datasheets/dtr30g2_us.pdf) . When copying from the flash drive to a mechanical hard drive using the original front USB port, Windows reported a consistent speed of around 138MB/s. Thus it seems that the original port is indeed USB3.0 at a minimum.

Here is what the device manager looks like. This is when the original front panel USB is connected and 2 of the Akasa's USB2.0 ports are connected (using a single 9-pin cable to the motherboard) Device manager

It lists the Texas Instruments XHCI Controller.

I have put the serial number in HP support site (per telcoM's suggestion) and it does list Texas Instuments USB 3.0 XHCI Host Controller drivers.

I will try to install them and report back.

Update 3: There were 3 drivers listed on the HP site. After installing either one of the two newest, even the original USB port didnt work. After installing the oldest one, the original USB port started working again, but the Akasa's still doesnt.

  • The documentation on this device is very sparce, I can't even tell if it takes THREE connections to the motherboard, one for USB 2.0, one for USB 3.0/3.1 Gen1, and one for USB 3.1 Gen 2, or only ONE? In some of the information it appears to be hub, and in others it appears to be only a panel for the connections off the motherboard. Have you contacted the manufacturer? – acejavelin Mar 16 '19 at 13:53
  • It has 3 connectors. One 9-pin USB2, one 19-pin USB3 and one for USB-C. The USB3 connector has two cables/wires connecting it to the device, I assume one for each of the 2 ports on the device. I have not contacted the manufacturer yet . – user2389946 Mar 16 '19 at 15:57
3

Looking at its manual, it seems like Akasa AK-HC-11BK is not an USB hub. It's basically just a mounting box that fits into a 5.25" drive slot to provide a front panel for mounting the connectors.

If it was a hub, it would need just one internal USB 3.x connection. Instead, it has one USB 2.0 cable (which typically handles 2 ports), one large USB 3.0/3.1 Gen1 cable (which handles 2 ports) and one cable with an USB 3.1 Gen2 connector (with a more slender connector but a typically quite stiff cable), which handles a single USB Type-C port.

Since the number and capabilities of the cables exactly matches the configuration of the ports in the front panel, I'd assume that all those cables are simply directly wired to the respective ports. So, referring to the letters in the manual's picture:

  • to make the USB 2.0 ports (a) work, you'll need to plug in the USB 2.0 cable (e).
  • to make the USB 3.1 Gen1 ports (b) work, you'll need to plug in the USB 3 cable (d)
  • and to make the USB 3.1 Gen2 Type-C port (c) work, you'll need to plug in the cable (f).

And the technical specifications of your motherboard seem to say that it only has 4 internal USB 2.0 headers - no USB 3.x headers at all. The service manual says otherwise.

Furthermore, Intel says the H67 chipset only has USB 2.0 support. So any USB3.x support with this chipset must come from an add-on USB3 controller on the system board. Does the Windows Device Manager indicate you have one?

Searching for "HP Elite 7300 MT", I found this specification page from HP. It confirms the system uses Intel H67 chipset, and your "Pegatron 2AB5" specification concurs. On "USB Support", it says:

EHCI high-speed USB 2.0 controller
Fourteen (14) internal ports on system board:
    4 for front ports
    4 for rear ports
    1 for media card reader
    5 reserved for future upgrade
External USB 2.0 ports:
    Front: 4 (two (2) USB 3.0 and two (2) USB 2.0)
    Rear: 4 (USB 2.0)

Note that only an EHCI USB 2.0 controller is listed: that means no USB 3.x, period. And although it says there are supposed to be two USB 3.0 ports at the front panel, the title for that section is "External USB 2.0 ports"???

As it turned out that your system actually has a Texas Instruments XHCI USB 3.0 add-on controller on the motherboard, my next guess would be that the 19-pin header could be based on a preliminary version of the relevant standard, and so be just different enough to only work with the cable and ports that come with the chassis itself.

| improve this answer | |
  • The motherboard actually has the 19-pin USB3 connector. I now realize that the link to HP site might not be the exact model. Anyway the other site (findlaptopdriver.com) came back on, so I have updated my post with screengrab of that. That site states that the motherboard has 2 USB3.0 connectors, which I assume is the one 19-pin. – user2389946 Mar 16 '19 at 16:14
  • I've edited my answer. Unfortunately it still looks like the system might not have real USB 3.x hardware in it. – telcoM Mar 16 '19 at 20:58
  • Seems you were right about the 3rd-party USB3.0 controller, see update 2 to my question. – user2389946 Mar 17 '19 at 18:23
2

HP Elite 7300 Microtower

According to HP service manual, the PC may or may not be configured with USB 3.0 ports. While the mainboard pictures do show the 2x10 2-mm pitch "mid-board" connector (circled in red):

enter image description here

the manual doesn't mention any 20-pin USB 3.0 cable extention. More, in this particular picture the USB 3.0 back connector seems to be non-populated.

My hunch is that at the time of PC release the Intel USB 3.0 controller was not yet functional, and thus resulted in crippled line of mainboards.

In short, it looks like you need to forget about having USB 3.0 front panel using the Akasa front extender on this specific 7300 Microtower PC.

| improve this answer | |
  • It seems the MB uses 3rd-party USB 3.0 controller, see my update to the original question – user2389946 Mar 17 '19 at 18:22
  • @user2389946, you should post the exact mainboard picture in first place, and describe USB connectors before everything else. If your system works with front panel USB 3.0 made by reputable system manufacturer, why would you try to replace it with some junk no-name hack? Good internal USB 3.0 super-speed extenders are tricky to make and matching proper impedances is difficult. – Ale..chenski Mar 17 '19 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.