2

Edit/Summary: I will not have physical access to the computer for the next month (it's at my parent's house and I live abroad), but from reading the comments, I believe a deep cleaning of the internals is a great suggestion, and I will as soon as I get back. I will also replace the MB battery, though the latter seems fine (read below for details). But if you have any proposed solutions that don't require physical access, please express them as I do have Teamviewer access.

I'm having a very weird issue where my computer instead of shutting down will blink for around 3-5 seconds (the sleep-state slow blink) and then it will start up/wake up again on its own. The same happens when I choose to "Sleep".

Things I have tried:

  • Resetting Windows 10 using the Troubleshoot at boot
  • Resetting BIOS settings to default (disabled wake on LAN)
  • Updating all drivers. BIOS last official update Dec. 2015. Installed since early 2016
  • Disallowing Wake Events to wake PC.
  • Disabling Hibernate/Hybrid Sleep
  • Checked all devices in Device Manager and disabled Allow device to wake computer when available (only the LAN driver had such an option).
  • Removed all cables except mouse/keyboard/monitor. (no wifi)
  • Checked the physical Power Button
  • Disabled Windows Maintenance Activator and manually ran the maintenance tasks
  • powercfg waketimers returns nothing
  • powercfg -DEVICEQUERY wake_armed returns NONE
  • Unfortunately I had System Restore disabled so I cannot restore to a previous point
  • Threw away my very weak UPS and connected directly to power strip
  • Cleaned the graphics card because its position seemed kind of odd. Rest of the insides have been last cleaned in December
  • Checked condition of motherboard battery: it's fine (after draining the capacitors and cutting power to the PSU for a minute, system time is still correct (50ms ahead)). I will replace it anyway when I get back.

The issue still persists.

When I run powercfg /lastwake I get nothing useful (no wake source), and when browsing Event Viewer, I get Wake Source: Unknown.

Now I'm simply out of ideas. Could it be some kind of motherboard issue? This computer is 10+ years old (battery works fine), but it has been running Windows 10 fine since it came out, and the BIOS was last updated 2015.

Edit: I believe this question is not a duplicate of the one suggested because of two reasons: - I have already read the whole post and the proposed solutions did not help my case. - The duplicate answer suggested has no mention of shutdown issues: only sleep is mentioned. - My issue occurs only seconds after sleep/shutdown regardless of time, suggesting that a scheduled task is not the issue. Therefore I believe that a different answer/solution is applicable.

  • Has it always done this or is something recent, we need more background info. Your bios may Not be compatible with W10 and there may be no cure on a 10 year old PC. – Moab Mar 16 '19 at 14:52
  • The computer has been running Windows 10 fine since it came out. The BIOS version is from 2015. This issue started about a month ago. – GM 180 Mar 16 '19 at 16:53
  • 2
    How is this a duplicate? It is a shutdown issue not a sleep issue. @harrymc – Moab Mar 16 '19 at 18:46
  • (1) Did you try illicious’s answer (disassemble and clean)?  (2) Did you run powercfg /waketimers (mentioned in two answers)?  (3) Do you have Wi-Fi?  What have you done to verify that the Wi-Fi is not the source of the problem? … … … … … … … … … … … … … … If you’re going to say “the proposed solutions did not help my case”, we like to see specifics.  I have voted to reopen on general principles, but please edit your question to say specifically what you have tried. – Scott Mar 16 '19 at 20:26
  • Windows should be shutting down. If it doesn't then its a Windows problem. If the computer goes through the entire boot process I'd be very surprised but that would be a motherboard/bios problem. If its a Windows problem, it might be best to nuke it and do a fresh install with latest download image - of course, it could be a recent update and then that would be a problem. No one here will probably know so I think only testing will help. Suppose too maybe some Windows bug where it didn't actually shutdown properly might also cause pc to go through full boot (maybe but doubtful) – CmosBattery Mar 17 '19 at 2:55
1

I found the problem - it was the BIOS battery. It seemed to hold a charge when I first tested it, but I guess the voltage was too low. Replacing it fixed the weird behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.