My computer was recently on a LAN with a squid proxy. After returning to my home network, certain applications (that I'm assuming were proxied) are still attempting to connect to the local proxy (, seen here: Connections outbound to stale proxy IP and port

These are the steps I've done to clear out any stale settings:

  1. Internet Options>Connections>LAN settings> uncheck "Automatically detect settings"
  2. ipconfig /release
  3. ipconfig /renew
  4. ipconfig /flushdns
  5. ipconfig /registerdns
  6. arp -d *
  7. nbtstat -R
  8. netsh winsock reset
  9. del \wpad*.dat /s
  10. created regkey HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\EnableAutoproxyResultCache:0

Additionally, when I run the network troubleshooter it shows that the "device or resource (www.microsoft.com) is not responding" Network Diagnostics Screenshot

I have no issues browsing to any website

I have no ideas on what to try next so feedback would be greatly appreciated, thanks!

  • 1
    Possible dupe: How Windows automatically detects proxy settings
    – DavidPostill
    Mar 17, 2019 at 17:23
  • In an admin cmd prompt, what does the output of running: netsh winhttp show proxy show? You should run it from \windows\syswow64\ as well if it's 64-bit OS to see the setting for 32-bit processes. Does it say "Direct access (no proxy server)." for both? Mar 17, 2019 at 18:39
  • Wpad is not a file. Does the solution in the link given by DavidPostill help?
    – harrymc
    Mar 17, 2019 at 18:52
  • @HelpingHand Here is the output: C:\WINDOWS\system32>netsh winhttp show proxy Current WinHTTP proxy settings: Proxy Server(s) : Bypass List : (none)
    – effect
    Mar 17, 2019 at 19:33
  • In that case, run: "netsh winhttp reset proxy". Mar 17, 2019 at 19:34

1 Answer 1


Solution was:

  1. Run Command Prompt as administrator
  2. Verify current winhttp proxy settings: "netsh winhttp show proxy"
  3. If it shows "Proxy Server(s): IP Address:Port" do step 4
  4. Run "netsh winhttp reset proxy"

Since I am a new contributor I cannot mark a comment as the answer so thanks to @HelpingHand.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.