1

Today I got Fios gigabit internet. My desktop PC that has a MSI 970A-G43 Motherboard which I think is supposed to support up to 1000Mbps but I'm only getting around 300-400Mbps download and 600Mbps upload on an Ethernet connecting with a Cat6 cable.

The technician who installed Fios connected his Verizon tablet (that runs android) to the same Ethernet cable and consistently got around 700-900Mbps down. On my laptop I'm getting around 600-700Mbps down.

The technician said my CPU could be the reason why my speeds are down. Should the CPU affect the test speeds at all? I have an AMD FX 6300 and an ADATA SU800 1TB SSD that according to their site has a

"Sequential R/W performance (max) of Up to 560/520MB/s
*Actual performance may vary due to available SSD capacity, system hardware and software components, and other factors"

For most of the tests I used https://www.speedtest.net to test the speed but I also tried Google's speed test that yielded about the same results. The technician did the test on his tablet using the app version of www.speedtest.net but he also installed another speed test app upon my request to prove that the results were the same, which they were.

I have updated my network card drivers, tried many other speed testing sites, disconnected and reconnected the Ethernet cable, restarted my PC, made sure not other programs were downloading anything, tried different web browsers. I'm using Fios G1100 Quantum Gateway router.

The problem is clearly linked to my desktop PC's hardware or settings but what else could it be? Even though my motherboard says it supports up to 1Gbps, could it be that the other components are not good enough to handle 1Gbps?

Update:
I have noticed that in Task Manager: Before speed test, SSD usage is 0% and stays at 0% during the test so I don't think the SSD is the bottle neck. Before speed test RAM usage is 50% (4GB out of 8GB) and that didn't really change during the test. Before the speed test, CPU usage fluctuates around 30-45% and stays the same during the test. I have also tried turning off the Windows Firewall during the test but made no difference.

  • It’s most likely a bottleneck in combination of your SSD. Please provide the necessary information about your SSD. – Ramhound Mar 17 '19 at 21:24
  • @Ramhound I added the SSD specs. You probably already know this but just to make sure, the SSD speeds I posted are in megabytes while the internet speeds are in megabits. – Jorge Luque Mar 18 '19 at 0:51
  • Rarely, if ever, are you going to get the maximum speed of your NIC. Not only is latency throughout the networks an issue, the are probably also other devices, etc that aren't running at that speed. It's only going to go at the speed of the slowest device in the chain. – Nasir Riley Mar 18 '19 at 1:15
  • 1
    It would be under the network adapter in device manager. Download jperf on both PC's, I also believe they need the Java runtime environment. Set the computer that you know is faster as the server. This should allow you to test adapters, network cables ect, and get relatively accurate results. If you still find you have a bottleneck, try testing against the loopback adapter (127.0.0.1) of the computer in question. Not all network adapters are built equally... You may want to check out PCI-E adapters for this tower, I've had pretty good results with the Intel pro series hitting advertised speeds – Tim_Stewart Mar 18 '19 at 15:52
  • 1
    @jorge-luque go to Device Manager, Network adapters, your network adapter, properties, Advanced. On there you will see a handful (up to dozens) of advanced settings for your adapter. Look specifically for anything with "speed", "performance", or "duplex" in the names. Ensure that they're all set to "full duplex" and the highest performance option. Sometimes they default to lesser options. – shawn Mar 18 '19 at 18:00
1

So far I had only tried doing the speedtest using a web browser. However, I tried downloading the Windows Store app version of speedtest.net and I'm getting around 700-850mbps down and 600-943mbps up (about twice the speed compared to the web browser test).

I don't know if the way the app does the test is better, or if web browsers bottleneck the test but testing from my browser results in ~300mbps (highest ever was 500mbps) down while using the app results in ~700mbps (highest was .

Since my other device (laptop) did get around 600mbps at some point using the web browser test, maybe the way my Desktop PC runs the web browser is what slows down the speed.

|improve this answer|||||
  • 1
    Browsers simply aren’t designed with bulk data transfer in mind. Most speed tests use a lot of CPU power. – Daniel B Mar 20 '19 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.