0

I know there are questions about this that already exist, but none of them work for me.

I had this all working fine, and recently similar apps have been grouped again. In an attempt to track down which switcher is doing this, I've done the following:

  • Disable "Ubuntu Unity plugin" in ccsm
  • Disable "Application Switcher" in ccsm
  • Disable "Static Application Switcher" in ccsm
  • Disable the alt-tab key binding in settings->keyboard->shortcuts->Navigation->Switch Windows

Weirdly, if I set "Switch windows of an application" to alt+tab, I get the following warning:

  • The "Switch windows of an application" shortcut has an associated "Switch to previous window of an application" shortcut. Do you want to automatically set it to "Shift+Alt+Tab"? "Shift+Alt+Tab" is currently associated with "Switch to previous window", this shortcut will be disabled if you move forward.

If I click "cancel", it assigns the shortcut anyways, and then shift+alt+tab gives me the behavior I want, only backwards. Alt+tab still groups windows. I've read through all of the keyboard bindings in the keyboard settings, and cannot find a single one bound to shift+alt+tab.

Edit: If I then rebind to "Switch windows", the switcher displays as I want. I don't really know how this happened, but I guess it works now, so I'm happy.

Second Edit: This is causing issues again, putting the laptop to sleep and/or plugging in a thunderbolt caused the issue to reappear. Resetting it like I did earlier did not work and now I am stuck in grouped switcher

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.