0

I don't know for how long this has been going on, but my BIOS only detects 4GB (2x2GB) out of 8GB (total of 4x2GB). CPU-Z tells me I have 8GB of RAM installed and Windows tells me that I have 8GB (4GB usable). I have a 64-bit Windows 7 OS.

I've tried to take them out, dust them off and put them back in again.

SPECS:

  • CPU: Intel Core i5 760
  • MOTHERBOARD: ASUSTeK P7P55D-E PRO
  • RAM: 4x2GB Corsair XMS3 DDR3
  • GPU: AMD Radeon 280x

Edit: the problem solved itself out of nowhere

  • 1
    Forgot to add that I'm on 64-bit Windows 7 – cephlot Mar 19 at 17:33
  • Check in the BIOS if you are running in single channel mode. Is your BIOS the latest? – harrymc Mar 19 at 17:42
  • According to CPU-Z, my BIOS is from 2012 so that's most likely a no – cephlot Mar 19 at 17:47
  • Your latest BIOS version is Version 1703 from 2012/08/01. If this is indeed your version, you can still reset it. – harrymc Mar 19 at 17:52
0

If the only place that the full RAM is not recognized is BIOS, is that up-to-date? Since the latest BIOS appears to be seven years old, though, that may not resolve the apparent issue.

Since you state Windows sees the full 8 GB (presumably in the System dialog), you might also check systeminfo.exe:

  • Press Windows, type cmd and select cmd.exe.
  • Type systeminfo and Enter.

This displays Total Physical Memory and BIOS version. You might also try HWiNFO64, portable or installed.

HWiNFO64 memory display for Toshiba laptop

You could test the RAM with the Windows Memory Diagnostic utility, but that requires a reboot and much time.

If the RAM is as expected, and all applications work as expected, then I'd assume this is a minor flaw in BIOS and ignore it. If it ain't broke, don't fix it.

-1

The problem solved itself. I installed java 64-bit and started technic launcher with 2.5GB RAM instead of one. When I exited the program, the screen flickered and it was back to normal

  • That doesn't make any sense. Installing Java and running a game isn't going to make your BIOS start recognizing more memory. – duskwuff Mar 19 at 18:49
  • I know. That's what happened though – cephlot Mar 19 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.