4

I need to change the NetBIOS Name under "System Preferences" -> "Network" -> "Advanced..." -> "WINS"; but I can click Ok, Apply or whatever; the OS will completely ignore my entry and keep the previous (default?) name.

Why the UI is broken? Why can't I set a different NetBIOS name from there? And how can I set it then?

UPDATE:

The UI doesn't show the change and will restore the previous value all the time I come back. But if I just change the value, "Apply" and close the window, then after a while the value I inserted will be taken in account and will be shown correctly. There's no logic in this, but just try to save the value, close, and come back in 3/5 minutes (rather than immediately) to check if now the change is there. It worked for me.

However, trying to trigger the name change I also touched the other fields and added a WINS server with IP "1.2.3.4". That had the same problem. But now also that one has been saved, together with the name and, no matter how much I try to delete that entry and wait for the change, that non-existent IP is always restored and I am no more able to have the "WINS Servers" list empty.

Does anybody has any suggestion? The UI carries this "completely broken" feeling and I dunno if I am incurring in a bug, if I am missing something, or if at Apple are lazy and sloppy on power-user features 🙁

  • Are you doing this from an admin account? Is the Mac under any kind of group policy control/MDM etc? – Tetsujin Mar 20 '19 at 17:20
  • Yes, of course I am running as admin as usual. About the MDM I don't think so; never had any company limitation (is there eventually some configuration place where to check?) – Kamafeather Mar 21 '19 at 0:04
  • You'd only really expect MDM etc if the machine is owned by a school or business. So unless it is, forget that idea for now. If it is, you'd have to ask whoever owns/manages the machines. Things to try: Test a brand new admin account. Test after safe boot. Overlay the OS again from Recovery. – Tetsujin Mar 21 '19 at 7:30
  • It's a business machine but was never managed by an admin; I was the only admin; there's an Exchange account but I doubt that's enough to lock the system (like it does on Android devices instead, for eventually wiping the data). – Kamafeather Mar 21 '19 at 11:34
  • Actually I noticed that the NetBIOS name is changed/saved, after many trials; looks like it doesn't change immediately when pressing "Apply", closing and reopening the settings (tried tens of times), but after a while the field has the value I put and the name responds to pings. 🤔- Just, now I put a random WINS server '1.2.3.4' trying to shake the settings and see if NetBIOS-name was changing. And now the same issue is with that field, since even if I remove the entry it will always be restored; and, no, differently from the Name field, this field doesn't take my changes just after a while 🙁 – Kamafeather Mar 21 '19 at 11:34
1

In regards to the settings being applied and saved within System Preferences, I do know that there is a bug in the UI where if you do not make your changes then completely close out (⌘ + Q) of System Preferences the change will not be reflected. It seems that System Preferences tends to cached the previous value until it is closed and relaunched.

| improve this answer | |
  • 1
    Nope, it is not the case, with my problem. I tried but the issue still remains. Good hint though! – Kamafeather May 2 '19 at 21:46
1

Do you use file sharing, if so, you will either need to turn it off prior to changing the netbios name, or, alternatively, go into system prefs, file sharing and change the computer name there. This should then change the netbios name once applied. Hope this helps

| improve this answer | |
  • 1
    Thanks for the suggestion; unfortunately it didn't really solved the problem. The behaviour is the same even if I disable File Sharing. The set WINS server will reappear all the times even if I delete it; and the NetBIOS name will be restored to the previous one. Also, the NetBIOS name and the ComputerName under Sharing (e.g. mypc.local) are not the same and don't seem to influence each other, when trying to set the second one. – Kamafeather Jul 1 '19 at 14:25
1

I had the same problem and I could not change NetBIOS name even after I changed it in Sharing > Computer Name and rebooting. But after I turned Wi-Fi off and on again NetBIOS name changed according to Sharing > Computer Name.

UPD: Above things did not help for long time. After I turned Wi-Fi on NetBIOS name returned to an old value after some minutes. But it seems I've found my root cause. My Mac has static IP in router's DHCP settings. The record in the table had Hostname which was my old NetBIOS name. It seems macOS was capturing this name from network. So, I just removed the record from the table and added it again with an empty Hostname. Now router does not tell my Mac what name it should take and the name is taken from local NetBIOS settings.

| improve this answer | |
0

By first turning off the network in System Preferences > Network (i.e. turn off wifi) and then changing the NetBios I was able to make the change permanent.

Turning the network back on, my NetBios was now showing the new value.

| improve this answer | |
0

Restarting the computer did not update the NetBIOS name but turning WiFi off and on did update NetBIOS within Network from Computer Name within Sharing.

| improve this answer | |
0

I found the answer with enough Googling:

WARNING: After doing this you can't remove the IP you added.

  1. Go to Network -> Advanced -> DNS
  2. Note the first IP
  3. Go to Network -> Advanced -> WINS
  4. Click the Plug Sign
  5. Enter the IP you noted in step 2
  6. Change the Workgroup and/or NetBios name
  7. Click OK
  8. Click Apply

I didn't check if the actual IP entered matters or not.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.