0

We are currently encountering a strange behaviour with Outlook when some users want to subscribe to an RSS feed.

We have an Intranet infrastructure which is a SharePoint 2016 on-premise installation that uses ADFS as authentication provider but also NTLM for some services.

For a reason we can't figure out, some users can't subscribe to RSS feeds that come from our SharePoint installation through Outlook. Outlook always returns that the content of the RSS feed can't be processed or the used link may not point to a valid source.

All of the users that encounter this problem are fully authenticated on their machine and can reach the SharePoint infrastructure without any problem. They can also display the various RSS feeds in their browser or subscribe to them through their browser. They are all referenced in SharePoint with at least read permission and synchronized in the Central Administration. The problem occurs on lists or library they have access to.

The RSS feeds coming from SharePoint are valid. In the beginning, we used a WebPart (Imtech CQWP) that displayed on a page some elements and a link to subscribe to a corresponding RSS feed. We thought this component was the problem, so we changed it for the standard CQWP, but the problem was the same. We also noticed that the problem occurs when users use the generated link for the RSS feed available in the ribbon of a list or a library, but only once. The first time they use the link, it fails, but if they try again, it works and they can delete and re-add the feed as many times as they want.

We followed the various HTTP requests that are sent when the problem happens and in some cases, we noticed a 401 error, like if the users could not be authenticated when they make a request to our SharePoint installation from Outlook. We tried to add user accounts in two formats in our SharePoint installation (ADFS and AD), but the error still occurs, even when users have full control.

We tried various solutions from Microsoft, including the workaround where we have to synchronize the RSS feeds to the Common Feed List (https://support.microsoft.com/en-us/help/917125/error-message-when-you-subscribe-to-an-rss-feed-that-requires-authenti) or the trick with the registry key "HKCU\Software\Microsoft\Office\16.0\Outlook\Options\RSS\Disable" without any success. We even thought this was related to some characters in the generated URLs and we played with them many times, using encoded characters or not.

We are a large organization with a lot of complex rules, but we checked with the server team, network team and security team, and there is no rule or setting on this side that could block the connection between Outlook and SharePoint.

Most users use Windows 10 and Office 2016, but the problem occurs also with Windows 7 and Office 2010. Considering that our SharePoint infrastructure is up and running and it doesn't seem to be a security or network problem, it seems related to the Office installation or maybe the user profile, but we cannot find more documentation on this problem.

We tried many things for hours to understand why it doesn't work, but without any success. Has anyone encountered such a behaviour? Any suggestion would much be appreciated.

Best regards,

0

Does error only occurs to links from this SharePoint 2016? Can you add other subscriptions?

From the description, users can subscribe to them through browser and issue only occurs on the web mail, right?

Did you check the option 'Synchronize RSS Feeds to the Common Feed List (CFL) in Windows'as mentioned in File -> Options -> Advanced > RSS Feeds section.

It was also reported to be related with internet settings. Please open > Control Panel > Internet Options > Advanced > Security section. Uncheck “Do not save encrypted pages to disk”.

Does this issue occur to all users? We can also temporarily close antivirus software in case it was caused by their integration with Outlook client.

| improve this answer | |
  • Thanks for your answer. The problem happens only with the Outlook client. As you suggest, we tried the options related to the CLF or to the security settings, but without any success. However, there is a reverse proxy between users and the servers. Maybe we have to dig into this direction... – Lancelot Mar 22 '19 at 10:00
  • In case this issue was caused by software conflicts, please try performing a clean boot in Windows to check the result. – Perry Mar 25 '19 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.