0

I have to sync a 63GB folder containing 1313753 files using rsync to an external hard drive formatted with NTFS.

After a while of syncing with around 5MB/s (which is okay I think) I run into the problem that the file transfer rate goes down to zero (checking with iotop) for a while and after that only goes on with ~20KB/s. If I let it run in this state for some days I get some I/O errors in the rsync output and if I check the filesystem of the hdd on Windows it shows that it is damaged and needs to be repaired.

I tried on different systems and with different new hard drives - it's always the same behavior.

I tried with: CentOS 7 Machine, new external hard drive USB 2.0 connected, mounted with ntfs-3g Fedora 29 Machine, different new external hard drive USB 3.0 connected, mounted with ntfs-3g

If I try to sync this folder to an external hard drive formatted with ext4 it's working like a charme and without any errors.

What could be the reason for this trouble?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.