1

I have 2 Win 10 computers, let's call them A and B, both running version 1809. They are logged in with different Microsoft users. Both computers are managed by me so I have the credentials.

I have shared the Videos library on each of A and B with everyone (right-click Videos library --> "Give access to" --> "Specific people ..." --> "Everyone" --> "Add" --> "Permission level" to "Read/Write" --> "Share.").

Now B can see A under "Network" but A cannot see B. Moreover, there is an Nvidia Shield on the network and B can see this device under "Network" but A cannot see it either. If I sit on B, I can double click A under "Network" and I can grab files from it.

I have 2 related questions please:

  • How do I make A see B (and the Nvidia Shield; I suspect it is the same solution) under "Network"?
  • As mentioned above, I can access the A's shared files if I have access to B. I did not have to log in or enter any credentials for A. I find this undesirable; indeed, with the Nvidia Shield, for the first-time access to it from B, I had to enter some credentials specific to the Shield. I'm not sure why A is letting me bypass credentials when I'm trying to access it from B. Is this because I chose "Everyone" as indicated above? I also note that, even before I shared my Videos library, the Users folder on A was already accessible from B, again without credentials. My wish is that if someone on the network wants to access my files on A or B, they need to enter some credentials, at least for the first time they try to access. For example, I don't want a guest whom I give the wifi password to will have complete access to my shared files. Is there a way to achieve this?

p.s. Computer A runs MalwareBytes 3.7.1 Premium. Both A and B are using the "Private" network profile where "Turn on network discovery" and "Turn on automatic setup of network connected devices" are both on.


Edit: From computer A's explorer, if I type \\Shield\ I can access the Shield after I enter in the credentials. This is exactly what I'm looking for! Likewise, if I type \\B\ (where I replace B with the actual name of computer B), then I can access computer B after I enter the credentials. So let me rephrase the question:

Why don't the Shield and B show up under "Network" even though they are actually accessible and why is the situation for A not symmetric with the situation for B?


Edit 2: a diagram is requested. It is provided below. Solid line is for wired connections and dashed line is for wireless connections. enter image description here

  • First thing to do. get the IP addresses, open a cmd window and see if you can ping them from each other – JohnnyVegas Mar 21 '19 at 21:07
  • also, go to system properties, computer name tab, and make sure both have 'WORKGROUP' set as the workgroup name – JohnnyVegas Mar 21 '19 at 21:08
  • 1
    instead of using \\Shield, use the IP address of the shield. \\192.168.1.11 for example – JohnnyVegas Mar 21 '19 at 21:10
  • @JohnnyVegas For the Shield, using the IP works. Copying a large file ~ 50 GB from B to Shield works. Copying a similarly large file from A to Shield seems to fail: the Copying dialog box hangs and the estimated speed is very sluggish compared to the speed from B to Shield. A is wired connected to the Google Wifi, as is the Shield. B however is connected via wifi. – yurnero Mar 21 '19 at 21:19
  • @JohnnyVegas I can ping from A to Shield. Copying a medium file (~ 1GB) from A to Shield (from within Explorer) also fails near the end. Copying a small file ~20 MB works. – yurnero Mar 21 '19 at 21:23
2

Restarting the network fixed the issue regarding to @yurnero.

If restarting does not work please try the following.

This is an issue in Windows, this upgrade disabled the SMBv1 and there for the Browsing protocol (that use SMBv1 as a transport) does not work and cannot search the network using this protocol.

Please try do this for fixing the network lookup.

Or you can enable the SMBv1

  • Hey it turns out restarting the network (via the Google Wifi app) fixes the problem. Since you are the only one that answers here, if you edit your post to mention that, I will tick you. Thanks. – yurnero Mar 23 '19 at 20:31
  • Thanks, will do – Eliad Cohen Mar 24 '19 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.