Sometimes Windows (XP sp3) won't listen when I tell it to Restart/Shutdown/Logoff. Right away, a few things disappear from the system tray, and nothing is running in the Programs pane of Task Manager; then nothing happens. Even if I wait an hour (it's not just slow - it stops). I can launch new programs, fiddle with anything - the system's not sluggish - it just won't shut down.

How can I figure out which process is not listening to the shutdown command?

I'd really rather not just cut power / push the reset button. Is there a more forceful shutdown command? I've tried all of the command-line parameters for basic "shutdown" in the command shell.

EDIT: It appears this is affected by network connection availability - router needed to be reset, and when I did so the machine shut down quickly. Unplug the Ethernet cable, and the shutdown hangs. I think some process is looking for a network resource. For now, I'm not going to put more time into finding the culprit - just shows how some programmers assume the network will always be responsive. Thanks for the answers!


I'd have a look into the Event Viewer, probably in the System log or maybe Application log.

Some software will prevent shutdown, for example Virtual Machine software (I believe VMWare does, at least it does on OS X) will not allow you to shutdown / reboot while the guest OS is running.

Another idea would be to load each application you would normally have open and try to reboot after it has loaded. This may help you track down what you're opening when you can't reboot. It would be highly time consuming.


Another alternative is to drop the shutdown.exe program into Process Explorer and monitor it's behavior.


I find that sometimes when that happens, re-issuing the shutdown again or a few more times seems to help it along. Also, manually closing programs during the shutdown, especially ones in the tray (right click and select exit/quit for those that support it) during the shutdown seems to help.

  • Thanks for your answer, but as I said, I tried multiple versions of the "shutdown" command without effect. Also said that nothing was running in the Programs pane of the task manager (so there's nothing on the toolbar). Good things to consider, though. – Argalatyr Jul 28 '09 at 11:56

Is this something that started recently? If so, you always have the option to do a 'System Restore' back to a date previous to when this started happening.

Or you can drop a new shutdown.exe in and replace the current one to see if that is the issue.

It sounds to me that there was a change (possibly from a Windows Update) that is causing this issue.


  • good thoughts, but did not lead to a solution. – Argalatyr Jul 28 '09 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.