-1

I'm having trouble setting up a network of serial devices on a shop floor. I do have some basic networking experience but am not verbose in some of the more advanced settings.

I'm trying to setup a network of serial devices on a shop floor using the MOXA 2250A devices which are serial-to-wireless device servers. These 22550s have 2 serial ports which provide wireless functionality to some older serial equipment we have and they also include an ethernet port which can be set up for bridged mode. Right now, I connect to the serial devices using virtual COM ports on a PC set to the static ip address of the device and to the individual serial ports on the device.

The wireless device servers are connecting to a ubiquiti unifi AP and I'm able to connect just fine to the serial devices connected to the wireless device servers.

This is where it goes wrong. I would like to add a 3rd serial connection to the wireless devices through the built in ethernet connections on the devices and setting them up in bridged mode. I have some MOXA ethernet-to-serial device servers which are much cheaper than the wifi and would like to connect these to the wireless ones using the bridged ethernet connection.

As I mentioned, I have the devices configured in static ip address mode but I'm running into the issue where I'm unable to connect to the ethernet device servers that are bridged. The devices allow configuration through a web browser but I can't connect to the device on the other end of the bridge.

The MOXA support has mentioned setting the wireless devices to allow for gratuitous ARP where I add the IP and MAC address of the ethernet devices connected to the wireless ones and they also state that the AP must have passive client mode enabled (which they said is generally only available on Cisco type networking devices) but I don't believe the ubiquiti AP has that setting.

I tried setting the devices to DHCP with and without GARP but had no success. I'm not able to establish a serial connection to the ethernet connected device or even ping it. MOXA does have a device search utility which does detect the ethernet device but I'm unable to access it or change the settings through it when it's connected through the bridge.

An example setup is default gateway 192.168.1.1, wireless device server/bridge 192.168.1.100 (has 2 serial ports on it) and ethernet-serial device 192.168.1.101 (has 1 serial port) using static addresses and connect to them using a PC on the network connect by a switch. I did try connecting the PC directly to the wireless device and the PC (in DHCP) had a good internet connection.

If I'm understanding the purpose of GARP correctly, is it that the devices on the other side of the bridge aren't showing up on the network so we are forcing the device setting up the bridge to notify the rest of the network of the existence of this device? If that's the case, I don't know why my PC was able to establish an internet connection no problem when connected to the wireless device but the ethernet-serial device be unsuccessful.

0

Try setting the ethernet connected device to something else than 192.168.1.1 because you can not set it to the same ip as your default gateway. A bridge is no separate network segment. The device on the bridged ethernet port should be able to talk to the access point and acquire an ip via dhcp. You don't need GARP. Does your access point has ethernet ports? Connecting your ethernet devices to the bridged ports should work the same as connecting them to the access point ports.

  • Sorry for that typo, the ethernet connected device does already have a separate ip address (should have read 192.168.1.101) from the gateway address. The Access point only has one PoE ethernet port but its also connected to a switch. I have tried connecting the ethernet device to the switch and it works fine. The problem only comes up when connected via bridge. – Alex S Mar 22 at 23:29
  • So your ethernet device works using dhcp when connected to the switch but doesn't get an ip when connected to the bridge and is not reachable with static ip 192.168.1.101? Then the bridge is not working as it is supposed to. – xenoson Mar 22 at 23:34
  • Okay thanks for the information. That's what I was leaning toward but it seems strange that my PC is able to connect using the wireless device server in bridge mode. It seems to be something when the 2 devices are communicating with each other. It seems to be related to the post on superuser.com/questions/486164/… – Alex S Mar 22 at 23:40
  • What you say about the arp. As long as you have no strict ip/arp mapping in the router, it should be fine. What they exactly mean by "passive client mode" - don't know but rings a bell. This kind of thing has issues over wlan in my experience. This is the same as setting a virtual machine on your computer to bridged networking over wlan. Wlan needs hacks for that I guess. – xenoson Mar 22 at 23:44
  • oldwiki.archive.openwrt.org/doc/howto/… "The 802.11 standard only uses three MAC addresses for frames transmitted between the Access Point and the Station." – xenoson Mar 23 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.