3

A couple of months back (I think it was with v63), Firefox changed the way to disable autoplay from setting

media.autoplay.enabled = false

to setting

media.autoplay.default = 1    # or 2 for ask

and possibly

media.autoplay.allow-muted = false

This is all fine and good. But as of v66, this doesn't seem to work anymore, either - playback starts as soon as a page with a video in it gets loaded*. This occurs in a fresh profile with nothing changed but these settings.

Autoplay is still prevented when entering a url by hand/ reloading a page. The only cases that fail are clicking a link or being redirected (after a login, for example).

So my question is this: What is the current way to disable autoplay everywhere in Firefox v66?

*actually, only if it gets loaded in the foreground - background tabs don't start playback even upon receiving focus. Which isn't really the expected outcome from setting media.block-autoplay-until-in-foreground = true (the default value) if autoplay were either allowed or disabled completely, either.

Edit: The precise version installed is 66.0+linuxmint1+tessa, on the off chance that it makes a difference.

5
  • I have media.autoplay.default set to 1 and it works on youtube. Have you tried with a fresh profile?
    – tastytea
    Commented Mar 24, 2019 at 12:30
  • @tastytea I have now. No luck though :/
    – Entropy0
    Commented Mar 24, 2019 at 12:33
  • Is autoplay prevented when you reload the page or when you enter the URL manually?
    – tastytea
    Commented Mar 24, 2019 at 12:54
  • Yes. The only time something actually gets played if I click a link or get redirected (ie. after logging in somewhere).
    – Entropy0
    Commented Mar 24, 2019 at 13:02
  • 2
    Possible duplicate of Stop automatic video play in Firefox
    – Run5k
    Commented Mar 24, 2019 at 17:00

1 Answer 1

2

Firefox allows autoplaying if you visited the URL by clicking on a link on the same site. For example, if you are on Youtube and click on a Youtube link, autoplay will not be prevented. To disable autoplay in these cases, set

media.autoplay.enabled.user-gestures-needed = false

in about:config.

According to ghacks.net, this setting was originally introduced to stop videos from auto-playing on websites you didn't interact with. The effect that it overrides media.autoplay.default = 1 seems to be a bug.

4
  • Do you have a reference link for this? If so, please edit and add to your answer.
    – DavidPostill
    Commented Mar 24, 2019 at 13:05
  • Thank you, that was indeed the problem. But I don't understand why this used to work in v63-65 - that setting is not new 0o
    – Entropy0
    Commented Mar 24, 2019 at 13:06
  • @DavidPostill I found this out by trying. I found no source with an explanation.
    – tastytea
    Commented Mar 24, 2019 at 13:24
  • They recommend the same. media.autoplay.enabled.user-gestures-needed to false, also media.autoplay.allow-muted to false, keeping media.autoplay.default to 1, and unchecking the box in about:preferences#privacy to automatically play sounds.
    – Ganton
    Commented Aug 16, 2019 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .