2

Environment: I have a router (ASUS ROG GT-AC5300 x 1) in the middle of two switches (TP-Link TL-SG108E 4.0 x 2). The router's WAN port is connected to another router that provides Internet (out of scope). Both switches are on LAN ports. Computer 1 is plugged into switch 1. Computer 2 is plugged into switch 2. The ASUS router (not the Internet router) acts as a DHCP server and assigns dedicated IP addresses to both switches and both computers based on their MAC addresses. Everything is on the same subnet.

  • Internet router (out of scope)
    • Asus router (192.168.1.1/255.255.255.0)
      • Switch 1 (192.168.1.2/255.255.255.0)
        • Computer 1 (192.168.1.4/255.255.255.0)
      • Switch 2 (192.168.1.3/255.255.255.0)
        • Computer 2 (192.168.1.5/255.255.255.0)

Question: How do I configure my network to allow computer 1 to ping/RDP to computer 2? I can ping both switches from both computers, but I cannot ping/RDP to computer 2 from computer 1, or computer 1 from computer 2; seemingly because I need to configure my router to send requests for computer 2's IP through switch 2 and vice versa. I think I did this properly for computer 2 after a bunch of searching online by adding the following static route in my router (under "LAN" -> "Route" in its web GUI):

  • Network/host IP: 192.168.1.5 (Computer 2)
  • Netmask: 255.255.255.0
  • Gateway: 192.168.1.3 (Switch 2)
  • Metric: 2 (I don't really understand this but I tried empty and 2)
  • Interface: LAN

However, after saving this route, turning off switch 2, powering off the ASUS router for 30 seconds, booting the router back up, and turning switch 2 back on, I am still unable to ping/RDP computer 2 from computer 1 (or even from computers plugged directly into the router and not another switch). I am at a loss. Any help will be greatly appreciated!

  • I’m not sure it makes sense to have a single subnet partitioned into separate chunks connected by a router.  You might need to either eliminate your router (and just connect your switches to each other, and one of them to the Internet router), or make it two separate subnets. – Scott Mar 25 at 3:52
  • 2
    “Router” and “all on the same subnet” are mutually exclusive. So, somewhere the terminology has been lost in translation. Either you have two different networks connected via a router, or you have 1 network and absolutely no use or place for a router. Routers connect different subnets together. – Appleoddity Mar 25 at 4:52
  • @Scott, thank you for the suggestion about making different subnets. I will try this later today. – Network-Noob-Dood Mar 25 at 18:18
  • @Appleoddity, thank you for the lesson, and like I said to Scott, I think you are pointing me in the right direction. My subnets are messed up. – Network-Noob-Dood Mar 25 at 18:21
  • @PimpJuiceIT (lol @ the name), thank you for your input. The scope of my issue is only the LAN side of the router. I edited my post to try to make it more clear. I will also take a look at the Windows Firewall settings. – Network-Noob-Dood Mar 25 at 18:22
1

With the new details provided in your question, it is now clear this is not a routing issue.

What you have indicated, is that all systems are connected to the same logical network (192.168.1.x). In this case there is no routing taking place. The router is actually not involved at all. Instead, it would be no different in this case if you directly connected both computers together through a single switch.

In fact, this would be a good test for you to do, to prove it isn’t the router. Simply connect both computers to the same switch and see if you can ping now?

If I have interpreted your post properly, the answer will be that you still can’t ping the other computer.

At this point you should undo any routing or networking changes you made and go back to the basics.

This is a firewall issue on the computers, not a router issue.

  • I redacted my aforementioned static route settings and did some firewall tweaks and it is now working. Not sure how the firewall escaped me but I GREATLY appreciate the assist!!! :D – Network-Noob-Dood Mar 25 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.