25

On Visual Studio Code v1.32.3 on Mac OS, and for at least a few versions before this, I am often unable to create files and folders in the sidebar via the default key mappings of a and shift+a, and instead am greeted with a file search / filter.

enter image description here

Typing "a" brings up this filter instead of launching the create file input under the selected folder

Restarting Code restores the file and folder creation behavior for some time, then seemingly out of nowhere the filter behavior takes over again, so I imagine there must be some other key shortcut I'm hitting that toggles the filter behavior.

I don't see any mappings in the default key bindings for those keys that suggest the search / filter behavior is intended:

{ "key": "a", 
  "command": "explorer.newFile",                                     
  "when": "filesExplorerFocus && !inputFocus" },
{ "key": "shift+a", 
  "command": "explorer.newFolder",
  "when": "filesExplorerFocus && !inputFocus" },

I've tried searching the preferences for "Explorer", "Side Bar", and "Filter" but can't find any reference to this filter feature.

So finally my question, how can I restore the file and folder creation behavior or completely disable this filtering behavior? I'm quite happy with cmd+p for finding files.

Or is this a bug? Happy to post issue on GitHub if so.

4
  • do you solve this problem?
    – ada
    May 11, 2019 at 7:27
  • I have not solved this issue. Right now it is not happening to me, perhaps because of new version, however I've made a note to myself to open an issue on GitHub if I experience it again and will post the link here May 13, 2019 at 17:17
  • 1
    I asked at vscode repo and answered below :)
    – ada
    May 14, 2019 at 9:01
  • 1
    Most f***** annoying thing ever it takes over my keyboard whenever making new files grrrr
    – Dominic
    Jan 14, 2021 at 15:43

3 Answers 3

32

as of vscode 1.33.1 the option is a bool "workbench.list.automaticKeyboardNavigation": false

EDIT: this setting has been deprecated, see discussion below for possible solutions. Will update when resolved.

7
  • 2
    I don't know why this got downvoted. This is the correct answer as of June 8th 2019.
    – Adam Reis
    Jun 8, 2019 at 10:08
  • 1
    Oops, I think I down-voted by mistake. Just upvoted and marked as accepted answer. Jun 24, 2019 at 16:50
  • For VScode 1.36.1 this answer is still correct.
    – Plopp
    Jul 11, 2019 at 12:12
  • If you go to settings and paste workbench.list.automaticKeyboardNavigation into the search bar, the setting should pop up and you can set it to what you want.
    – Pro Q
    May 15, 2021 at 10:02
  • This answer does not seem to be correct anymore in 2022, there is no such setting. Sep 18 at 0:56
3

UPD see Thomazella's answer

Old use this setting "workbench.list.keyboardNavigation": "simple" and then reload window

source

2

Thomazella's answer isn't working anymore in 2022. bradonomics mentions modifying the keybinding. There probably are two matches if you search for 'listSupportFind', I deleted the cmd + f one and it's all good now

Here is a screenshot of keybindings after deleting one of the two shortcuts

5
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Sep 20 at 9:10
  • 1
    This should be the top answer Sep 28 at 14:21
  • @DavidSchumann I tried that and it didn't seem to do anything. Pressing a or shift+a is not making a new file. I deleted all keybindings as suggested. I think it's because those bindings were for F3 presses, maybe unrelated? see github link. Not sure how to fix myself ATM.
    – Thom
    Sep 29 at 22:14
  • 1
    @Thom what do you mean? a or shift + a are no known shortcuts or am I missing something? On Mac simply hit [CMD + K + (CMD) S] and then search for the listSupportFind bindings, and delete the one you don't want Oct 1 at 15:38
  • 1
    @TrainedMusician 's recommendation worked for me
    – soutarm
    Oct 4 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.