2

I finished uploading my files to Google Drive using File Stream and don't have anything marked to be kept local. Still, GDFS keeps around 40GB of cache files.

Here are the things I tried to make it clean it up:

  • Ejected the drive, logged out, closed the app, opened the app, logged in;
  • Restarted the computer;
  • Added/deleted more files to see if it would "refresh";
  • Changed the cache folder location in preferences. It transferred all files and still left 1GB in the older folder [facepalm];
  • A combination of the things above in different order.

I think I can just delete the cache folder but it's something I don't want to do. How can I force it to delete? More importantly, is this the expected behaviour?

I'm using macOS 10.12.6

2

On macOS, execute the following command: defaults write com.google.drivefs.settings ContentCacheMaxKbytes -int 100000

On Windows, save the following content to a file called google.reg and execute it, or alternatively, add the registry key yourself (QWORD, decimal value 100000).

Windows Registry Editor Version 5.00    
[HKEY_LOCAL_MACHINE\SOFTWARE\Google\DriveFS]
"ContentCacheMaxKbytes"=hex(b):a0,86,01,00,00,00,00,00

This will cause Drive File Stream to delete the cache once it hits 100mb. By default, Google selects a high value to decrease access to its cloud.

Reference: https://support.google.com/a/answer/7644837?hl=en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.