0

I've set up an asterisk server in a VM and set the networking mode to Bridged. I'm trying to make a call using sipML5 demo from another computer in my LAN. It's receiving the SIP packets as desired but the RTP packets are sent to the public IP instead. I've set nat=no but the problem still persists.

Here's my sip.conf -

[general]
udpenable=yes
tcpenable=yes
preferred_codec_only=yes
disallow=all
allow=alaw
allow=ulaw
sipdebug=yes
canreinvite=no
invite=no
encryption=yes
avpf=yes
context=public

[sipML5]
type=friend
context=outgoing
;host=dynamic
dtmfmode=auto
disallow=all
allow=ulaw,alaw
directmedia=yes
nat=no
host=dynamic
canreinvite=no
invite=no
encryption=yes
avpf=yes
transport=wss
dtlsenable=yes
dtlscertfile=/etc/asterisk/keys/asterisk.crt
dtlsprivatekey=/etc/asterisk/keys/asterisk.key

And after setting rtp debug to on in the cli , I see this -

       > 0x7fbed8006b40 -- Strict RTP learning after remote address set to: x.w.y.z:33726
    -- Executing [100@outgoing:1] Answer("SIP/sipML5-0000001f", "") in new stack
    -- Executing [100@outgoing:2] Wait("SIP/sipML5-0000001f", "1") in new stack
    -- Executing [100@outgoing:3] Playback("SIP/sipML5-0000001f", "please-try-again") in new stack
Sent RTP packet to      x.w.y.z:33726 (type 00, seq 014611, ts 000160, len 000160)
    -- <SIP/sipML5-0000001f> Playing 'please-try-again.gsm' (language 'en')
Sent RTP packet to      x.w.y.z:33726 (type 00, seq 014612, ts 000320, len 000160)
Sent RTP packet to      x.w.y.z:33726 (type 00, seq 014613, ts 000480, len 000160)

Where x.w.y.z is my public IP. This just sends the packets and I don't receive any audio. Appreciate any kind of suggestions.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.