0

Ubuntu 18.04 LTS orca 3.28.0

Unity or Gnome desktops, same issue

Have a project that requires review with a screen reader and Orca/Gnome Orca Universal Access is not working at all.

System Settings->Universal Access-> Screen Reader = On and Profiles -> Show accessibility profiles indicator on are the only system settings changed. In the profiles dropdown, "Screen reader with speech" is selected. Got nothing! says it's running.

~ $ ps -aux | grep orca
bill      3114  6.1  0.3 568808 56864 ?        Sl   09:36   0:03 /usr/bin/python3 /usr/bin/orca
bill      4886  0.0  0.0  23612  1120 pts/0    S+   09:37   0:00 grep --color=auto orca

Killed the process and tried to launch via terminal per the docs (orca -s below,) this brings up the screen reader settings GUI. When I hit apply/ok without making any changes,

~ $ orca -s
Gtk-Message: 10:06:40.804: GtkDialog mapped without a transient parent. This is discouraged.

(orca:10122): Gtk-CRITICAL **: 10:07:19.625: gtk_notebook_get_tab_label: assertion 'list != NULL' failed
[Previous repeats 7 times)

/usr/lib/python3/dist-packages/pyatspi/Accessibility.py:184: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Atspi.Event.host_application = property(fget=lambda x: x.source.get_application())

Leaving this terminal window open, the "repeating line" above continues to output, I am guessing this is occurring at events where it is supposed to "speak."

CTRL+C that process I get

(orca:10122): dbind-WARNING **: 10:11:58.950: DeregisterKeystrokeListener failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

killed the orca process and re-launched via command line. Hesitates for 1-20 seconds, then

(orca:25886): dbind-CRITICAL **: 10:15:03.756: atspi_accessible_set_cache_mask: assertion 'accessible == accessible->parent.app->root' failed
 /usr/lib/python3/dist-packages/pyatspi/registry.py:155: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Atspi.event_main()
/usr/lib/python3/dist-packages/pyatspi/Accessibility.py:184: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Atspi.Event.host_application = property(fget=lambda x: x.source.get_application())
/usr/lib/python3/dist-packages/pyatspi/Accessibility.py:56: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
return '[%s | %s]' % (self.getRoleName(), self.name)

Traceback (most recent call last):
 File "/usr/lib/python3/dist-packages/orca/generator.py", line 243, in generate
   result = eval(formatting, globalsDict)
  File "<string>", line 1, in <module>
NameError: name 'description' is not defined

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/orca/generator.py", line 254, in generate
globalsDict[arg] = self._methodsDict[arg](obj, **args)
 File "/usr/lib/python3/dist-packages/orca/speech_generator.py", line 220, in _generateDescription
result = generator.Generator._generateDescription(self, obj, **args)
  File "/usr/lib/python3/dist-packages/orca/generator.py", line 408, in _generateDescription
   name = obj.name or ""
GLib.GError: atspi_error: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" could not be processed as object /org/a11y/atspi/accessible/1196 does not exist
(1)

(orca:25886): dbind-CRITICAL **: 10:15:21.081: atspi_accessible_set_cache_mask: assertion 'accessible == accessible->parent.app->root' failed
(Seven repeats of this line again)

I completely uninstalled and reinstalled both orca and orca-gnome, got nothing, no speech or sound.

Yes I checked sound is functioning properly. :-) Intersperse the above with several restarts (and checking in both Unity and Gnome desktops.)

I found one post with the exact same error, no answers.

Can anyone clue me in on what might be wrong? All the tut's and videos show a simple click of the on button in Universal Access and voila, it just works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.