1

I'm attempting to use TRAMP to for editing files remotely with Emacs (v 26.1), but I'm finding that it's nearly impossible to work without the connection constantly being re-established. This makes it impossible to work without constant interruption. Basically, just navigating inside the remote file yields the following lines every 3 seconds:

Tramp: Opening connection for artku750@abel.uio.no using ssh...
Tramp: Sending command ‘exec ssh -q -l artku750  -o ControlMaster=auto -o ControlPath='tramp.%C' -o ControlPersist=no -e none abel.uio.no’
Tramp: Waiting for prompts from remote shell...done
Tramp: Found remote shell prompt on ‘abel.uio.no’
Tramp: Opening connection for artku750@abel.uio.no using ssh...done

I don't have great intuition for why this is happening and nothing in previous, related questions seems to help (i.e. projectile-mode, setting a local auto-save dir). This is likely an easy fix, but I unfortunately haven't figured it out yet.

I'm running Spacemacs with Emacs 26.1 on OSX Mojave 10.14.4.

Any help would be greatly appreciated. Thanks!

  • Pls check, whether this happens also with emacs -Q. If the problem persists, set tramp-verbose to 10, and rerun the test. Show the resulting Tramp debug buffer. – Michael Albinus Mar 28 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.