0

I followed this tutorial https://howtoprogram.xyz/2017/08/09/how-to-install-activemq-on-ubuntu-16-04-lts-xenial-xerus/ to install ActiveMQ manually and everything worked fine and i was even able to access the webhost on http://127.0.0.1:8161. But I tried the sudo apt-get install automatic option out of curiosity and though it was also successful, I cannot access the web console for both installations now though I am able to start them. Below are snippets of the output:

● activemq.service - LSB: ActiveMQ instance
   Loaded: loaded (/etc/init.d/activemq; generated)
   Active: active (running) since Thu 2019-03-28 22:52:17 GMT; 3s ago
     Docs: man:systemd-sysv-generator(8)
   Process: 14696 ExecStop=/etc/init.d/activemq stop (code=exited, status=0/SUCCE
   Process: 15233 ExecStart=/etc/init.d/activemq start (code=exited, status=0/SUC
Tasks: 31 (limit: 4915)
CGroup: /system.slice/activemq.service
       └─15265 /usr/lib/jvm/default-java//bin/java -Xms512M -Xmx512M -Dorg.a
Mar 28 22:52:11 sys-abj systemd[1]: Starting LSB: ActiveMQ instance...
Mar 28 22:52:11 sys-abj activemq[15233]:  * Starting ActiveMQ instance  activemq
Mar 28 22:52:17 sys-abj activemq[15233]:    ...done.
Mar 28 22:52:17 sys-abj systemd[1]: Started LSB: ActiveMQ instance.

and a netstat to the transportConnector tells it's listening by yielding this result:

 tcp6       0      0 127.0.0.1:61616         :::*                    LISTEN      15265/java   

However, any time I point to 127.0.0.1:8161, I get no feed back.

I stumbled upon this https://stackoverflow.com/questions/14020283/how-to-install-or-config-activemq-admin-cosolejetty-use-apt-get-command link but I still can't wrap my head around how to configure the web console.

Any help would be much appreciated

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.