1

I have found that to receive files on my PC, I must first right-click the Bluetooth icon in the taskbar and select "Receive a file".
Windows 10 receive Bluetooth file manually
Then I can send the files from the phone by selecting `Share > Bluetooth > [PC Name], and they will begin to transfer.

If I try to send a file from phone to PC without first choosing to receive a file on the PC, the phone quickly shows that the transfer was unsuccessful

Is there any way for me to either:

  1. Send files from a phone and have them automatically received without confirmation on the PC?
  2. Send files from a phone and then accept to receive them on the PC afterward?

I know that with my previous PCs, I could simply send files from any of my Android phones by selecting Share > Bluetooth > [PC Name] and at then the PC would show a dialog asking if I want to receive the file(s). After confirming, the transfer would begin. I don't fully grasp what made them different, as I didn't personally install anything bluetooth related on them.

  • The simplest solution is to send the files via email to yourself. – harrymc Mar 29 at 14:51
  • @harrymc - Perhaps, but email is not always possible due to lack of a network connection. Plus many email services block certain file types and sizes, adding even more extra steps. – Bort Mar 29 at 14:59
2

If you're asking what has changed, then Windows itself has changed, to protect you against unwanted files. Microsoft has now published the procedure they impose in the article Share files over Bluetooth, which is exactly as you have observed.

Should you wish to avoid this procedure, your options are to either use email or a third-party application.

Examples of such applications are Join (free) or Pushbullet (limited free account).

Another possibility is to install on the phone an application for an SSH server, for example on Android the SSHDroid, then use for example WinSCP on the PC to directly access the folder on the phone from the PC.

  • Was this change implemented in Windows 10? – Bort Mar 29 at 15:44
  • Yes, it happened after one of the major updates. I don't know exactly when, since I don't transfer files that often. I thought also of another option which I added. – harrymc Mar 29 at 15:46
  • @MikePetrichenko - It seems this was a recent change. – Bort Mar 29 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.