1

I'm trying to learn RobotFramework, and this the first code:

* Setting * Library SeleniumLibrary

* Test Cases *
FirstSeleniumTest Open Browser https://google.com chrome Close Browser

but I received this failure error:

WebDriverException: Message: 'chromedriver' executable needs to be in PATH. Please see https://sites.google.com/a/chromium.org/chromedriver/home

I have tried almost everything what I could find by search, the chromedriver is in my /usr/local/bin/ and the project itself also /Users/arash/Documents/SeleniumDrivers

the echo $PATH is: /Library/Frameworks/Python.framework/Versions/3.7/bin:/Library/Frameworks/Python.framework/Versions/3.7/bin:/usr/bin:/usr/sbin:/bin:/usr/local/bin:/sbin:/opt/x11/bin:/Users/arash/Documents/SeleniumDrivers

I have tried brew, .bash, /etc/paths adding too.

please help me to figure out what is the problem.

Eclips screenshot

closed as unclear what you're asking by Scott, DavidPostill Mar 31 at 9:54

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.