1

I installed a 1 TB Samsung 860 EVO m.2 SSD into my laptop today. I formatted the drive using the Windows Disk Manager tool. The laptop is installed with Windows 10 on a 2.5 inch HDD drive.

I then tested the m.2 drive by copying some photos to it and that worked fine. To do a more precise check of the drive I tried running CrytsalDiskMark, this appeared to work fine but after the sequential read test the program appeared to hang and I got a BSOD shortly afterwards.

The stop code was DPC WATCHDOG VIOLATION. The laptop restarted and appears to be working normally. I've installed the Samsung Magician software and it is reporting the drive condition as good and the drive has the latest firmware installed.

1

Turns out it was a driver issue with Windows 10.

The fix from Samsung support was:

Please be informed that the DPC_WATCHDOG_VIOLATION error message is directly linked to Windows 10.

This error may occur due to the iastor.sys driver, which is not fully compatible with Windows 10.

Microsoft is currently investigating a solution to prevent the driver from being migrated when upgrading to Windows 10. For those of you already on Windows 10, you can work around this error by replacing the problematic driver with the Microsoft storahci.sys driver by following these steps:

  1. Right-click the Start icon and select Device Manager.
  2. Expand IDE ATA/ATAPI controllers.
  3. Select the controller with “SATA AHCI” in its name (such as Standard SATA AHCI Controller). To verify that you’ve selected the right controller, right-click the controller, select Properties, click the Driver tab, and then Driver Details. Verify that iastor.sys is a listed driver, and click OK.
  4. From the Driver tab, select Update Driver…
  5. Select Browse my computer for driver software.
  6. Select Let me pick from a list of device drivers on my computer.
  7. Select Standard SATA AHCI Controller.
  8. Click Next, then Close, and then restart your computer.

If the above solution does not work, please try turning off Windows fast startup in Power Saving option.

I followed these instructions and was able to successfully run CrystalDiskMark.

1

I came across this issue recently with a 500GB Samsung 860 EVO SATA, but it surprised me as I have a 1TB drive of the same model in the same machine with no problems.

My machine has two SATA controllers, and it turns out that the failing drive was attached to a SATA port on a controller configured as RAID. Moving the drive to the controller configured as AHCI fixed the problem. As I didn't leave the drive on the original controller (and change the controller from RAID to AHCI) I can't be 100% certain that is the problem; however from memory I'm pretty certain that all the ports I used were controlled by the same chipset so it's unlikely to be due to controller chipset differences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.