0

So, I have an old Toshiba Satellite laptop (intel processor, 8gb ram, dedicated and on-board graphics, 1tb/4gb HDD/SSD combo drive) that I was trying to install Linux on. It had windows 10 on it and it's been slow for a while now. First I burnt a basic Debian CD and installed it (I've now also tried a ubuntu CD. Scripted reboot after installation is fine and it loads into Gnome. It has an ethernet connection so acquiring packages is not a problem. The issue is that on any subsequent reboot, I am greeted with either a
reboot and select proper boot device or insert boot media (indicative of checking disk slot)
or
Checking media presence...... Media Present...... Start PXE over IPv4, Press [ESC] to exit.
(indicative of checking for boot-by-LAN)

Now, my boot order is HDD, ODD, USB, LAN. (I've also tried telling the computer to specifically boot from the HDD, but it just skips to something else) I have no USB plugged in, so it is clearly not recognizing that there is an OS on the HDD and moving on to the next step. The installer for Debian, Ubuntu, and the BIOS have never failed to see that there is a hard drive there, but after a reboot that wasn't scripted by an installer, the computer doesn't seem to be able to start the OS.

I've also tried swapping out the stock (old) hard drive that came with the pc with a new SSD I ordered online. Same results; installers/BIOS can see the drive, and can boot directly after installation but will not boot from HDD. This PC was working (albeit very slowly) just fine 2 days ago with windows 10.

ALSO (probably also important), when I was moving files off of my computer, I noticed that in some cases, when the computer was showing/calculating folder/file sizes, it was calculating completely wrong numbers. One folder was listed as over 3TB, wheras the hard drive for the entire computer was only 1TB. In addition, the computer has quickly flashed error messages during installation of either OS, which I could only briefly see and were something like ACPI Error: Method parse/execution failed E_LIMIT (20180531/psparse-516)

My real question is if it's a hardware issue that would make it beyond help, or if it's a software thing that I'm just doing wrong.

  • 1
    It sounds like the bootloader isn't being installed. Try creating the Debian image again. Can you post where you are downloading it from so we can double check you have the right one? Remember to put @Eric F in front of any comments if you are responding at all – Eric F Apr 1 at 18:08
  • Also, please clarify what OSes are now on your system and where each one is. – fixer1234 Apr 1 at 19:43
  • @EricF Debian image was downloaded from the debian site, the amd64 image; and the Ubuntu image was downloaded from the Ubuntu site here. Should I try getting a new image? – A D Apr 2 at 0:20
  • @fixer1234 Each time I installed debian or ubuntu again, I told it to use the whole drive, i.e. wipe the old OS. Currently I have debian on the SSD and Ubuntu on the HDD/SSD combo. The combo drive is plugged into the only Hard Disk slot in the laptop, and the other is currently in an external enclosure (I didn't just plug the enclosure in when I swapped them, I physically took the combo drive out and put the SSD in; I just don't have a better place to store it right now). – A D Apr 2 at 0:25
  • Each time you installed Linux of some variety, did you have the installer wizard handle disk partitions and related setup for you automatically or did you select to do it manually and then specify how to partition, where to put GRUB, etc.? Can you confirm that each GRUB was installed, and on the same drive as the OS installation (i.e., it could have found an existing GRUB on the other drive and asked you if you want to just update that one, in which case one drive may not even contain GRUB)? (cont'd) – fixer1234 Apr 2 at 1:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.