2

I have the configuration as follows. At my home computer I launch jupyter notebook on port 7000 and set up reverse ssh to my cloud server

ssh -f -N -R 9000:localhost:7000 cloud_user@cloud.hosting.com

I want to access jupyter from my laptop by

http://cloud.hosting.com:9000

But connection refused. Nevertheless, I can do (from the cloud server console)

wget localhost:9000

and it is working. And also: if I ran jupyter on the cloud server (say on port 1234) then http://cloud.hosting.com:1234 is working. What I have to do for accessing home jupyter from the laptop?

2
  • I think your cloud server firewall is getting in the way. What firewall do you use? – Guy Gastineau Apr 1 '19 at 22:17
  • I'm sorry but I don't really know. All settings are default (Ubuntu 16.04). If I run jupyter on the cloud server then I can access to it from the laptop – MrNewman Apr 1 '19 at 22:19
1

You need "-g" on that ssh command. "netstat -plnt | grep :9000" (on the cloud host) will show you the difference between your current command and the same with "-g".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.