0

After Jruby and gems had developed serious problems (most gem installs showed errors. I did not originally know of or use rvm), I am rebuilding the development side of the machine, which entailed:
- wiping the machine
- installing mojave
- deleting and reinstalling xcode
- restoring any old files I wanted.
- installing rvm from the Internet
- reinstalling jruby and ruby (2.6.2) from the Internet.

The xcode already had ruby 2.3.x. All of this went well with no error messages.

Then, I went to list all the rubies in rvm. I received the messages in listing 1 below. Since it suggested a remedy, I tried the first suggestion: gem pristine executable-hooks --version 1.6.0 Result was nearly a repeat of the first message.

Then I tried the second suggestion: gem pristine gem-wrappers --version 1.4.0. Result ditto. Means no progress.

Any suggestions how may I restore my gems for jruby to usable condition or do I need to start over yet again for the 3rd time?

Listing 1 shell output -

MacBook-Air:~ dbd$ gem list WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by org.jruby.util.SecurityHelper to field java.lang.reflect.Field.modifiers WARNING: Please consider reporting this to the maintainers of org.jruby.util.SecurityHelper WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations WARNING: All illegal access operations will be denied in a future release Ignoring executable-hooks-1.6.0 because its extensions are not built. Try: gem pristine executable-hooks --version 1.6.0 Ignoring gem-wrappers-1.4.0 because its extensions are not built. Try: gem pristine gem-wrappers --version 1.4.0 Ignoring jruby-launcher-1.1.9-java because its extensions are not built. Try: gem pristine jruby-launcher --version 1.1.9 Error loading RubyGems plugin "/Users/dbd/.rvm/gems/jruby-9.2.5.0@global/gems/executable-hooks-1.6.0/lib/rubygems_plugin.rb": no such file to load -- executable-hooks/wrapper (LoadError) Error loading RubyGems plugin "/Users/dbd/.rvm/gems/jruby-9.2.5.0@global/gems/gem-wrappers-1.4.0/lib/rubygems_plugin.rb": no such file to load -- gem-wrappers (LoadError)

* LOCAL GEMS *

bundler (2.0.1) bundler-unload (1.0.2) cmath (default: 1.0.0) csv (default: 1.0.0) did_you_mean (1.2.0) executable-hooks (1.6.0) fileutils (default: 1.1.0) gem-wrappers (1.4.0) ipaddr (default: 1.2.0) jar-dependencies (default: 0.4.0) jruby-launcher (1.1.9 java) jruby-openssl (0.10.2 java, default: 0.10.1 java) jruby-readline (default: 1.3.7 java) json (default: 2.1.0 java) minitest (5.10.3) net-telnet (0.1.1) power_assert (1.1.3) psych (default: 3.0.3 java) rake (12.3.2, 12.3.0) rake-ant (default: 1.0.4) rdoc (default: 6.0.1) rubygems-bundler (1.4.5) rvm (1.11.3.9) scanf (default: 1.0.0) test-unit (3.2.8) webrick (default: 1.4.2) xmlrpc (0.3.0) MacBook-Air:~ dbd$

0

Sorry. I did not search on the problem on the web. This turned out to be already posted to jruby dev site so it rates as a known problem. The posting is for jruby 2.5.0, while I am using 2.6.0. Unfortunately as far as I can tell, the only suggestion seem to be reinstall jruby (and gems???), which is not very satisfying since they do not seem to know why it is happening, and the issue is closed. I will try various installations and see what happens. If anything clearly works, I will follow up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.