when I run

docker exec -i -t transmission  df -h /media/TOSHIBA_HD/home-theater/

from /storage/.config/autostart.sh I don't get any output at all if I run it from ssh I get

Filesystem      Size  Used Avail Use% Mounted on
tmpfs           374M  2.6M  372M   1% /media/TOSHIBA_HD/home-theater

which I can use to know if transmission is mapped correctly or needs a restart

I am hitting my head against the wall, trying to figure out why my bash SSH terminal works nicely but the autostart.sh doesn't both run as root, I redirected the output to a log to see looped waiting a second - checking it again and again - and while my shell showed the correct output, autostart.sh STILL gives no output


turns out it was a flag issue, instead of running:

docker exec -i -t transmission  df -h /media/TOSHIBA_HD/home-theater/

I need to run:

docker exec -i transmission  df -h /media/TOSHIBA_HD/home-theater/

without the -t flag which requires a terminal.

found this out by searching the error “The input device is not a TTY” here https://stackoverflow.com/questions/43099116/error-the-input-device-is-not-a-tty

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.