0

I have come across an issue where VSC's in-built terminal uses a Linux based terminal rather than the system default terminal system.

How can I change the terminal environment back to the windows default?

I did at one point install the terminal environment when i was using the Hyper.js terminal however since then VSC's terminal has not been using the system default.

[VSC screen shot

0

I have figured out a solution to my problem, which is as follows:

  1. go to file > preferences > settings
  2. select workspace > features > terminal and scroll until you see this: settings
  3. look for "integrated > Env:Windows" and click "Edit in settings.json" It should look something like this
  4. locate "terminal.integrated.shell.windows": under user settings
  5. make sure the directory to point to "C:\WINDOWS\System32\cmd.exe"
  6. load terminal and check if works. if it doesnt then idk, this method worked for me.

I hope that this might help others in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.