0

Self-explanatory:

$ npm
npm: archivo no encontrado (file not found)
$ whereis npm
npm:
$ which npm
$ apt list npm
Listando... Hecho (listing, done)                   
npm/stretch-backports 5.8.0+ds6-2~bpo9+1 all

But dpkg:

$dpkg -L npm
dpkg-query: el paquete `npm' no está instalado.
Utilice dpkg --info (= dpkg-deb --info) para           
examinar archivos,
y dpkg - 

What's happening on this install? Which program is lying? I know it's dpkg, but why?

Surely there's something wrong on the bottom since:

$sudo apt-get install npm
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:
Los siguientes paquetes tienen dependencias incumplidas:
 npm : Depende: nodejs (>= 6.11~) pero 4.8.2~dfsg-1 va a ser instalado
       Depende: node-abbrev (>= 1.1.1~) pero 1.0.9-1 va a ser instalado
       Depende: node-ansi-regex (>= 3.0~) pero 2.0.0-1 va a ser instalado
       Depende: node-cacache (>= 10.0.4~) pero no va a instalarse
       Depende: node-config-chain (>= 1.1.11~) pero no va a instalarse
       Depende: node-glob (>= 7.1.2~) pero 7.1.1-1 va a ser instalado
       Depende: node-hosted-git-info (>= 2.6~) pero 2.1.5-1 va a ser instalado
       Depende: node-ini (>= 1.3.5~) pero 1.1.0-1 va a ser instalado
       Depende: node-npm-package-arg pero no va a instalarse
       Depende: node-jsonstream (>= 1.3.2~) pero 1.0.3-4 va a ser instalado
       Depende: node-libnpx (>= 10.0.1~) pero no va a instalarse
       Depende: node-lockfile (>= 1.0.3~) pero 0.4.1-1 va a ser instalado
       Depende: node-lru-cache (>= 4.1.1~) pero 4.0.2-1 va a ser instalado
       Depende: node-move-concurrently (>= 1.0.1~) pero no va a instalarse
       Depende: node-normalize-package-data (>= 2.4~) pero 2.3.5-2 va a ser instalado
       Depende: node-gyp (>= 3.6.2~) pero 3.4.0-1 va a ser instalado
       Depende: node-resolve-from (>= 4.0~) pero 2.0.0-1 va a ser instalado
       Depende: node-npmlog (>= 4.1.2~) pero 0.0.4-1 va a ser instalado
       Depende: node-osenv (>= 0.1.5~) pero 0.1.0-1 va a ser instalado
       Depende: node-read-package-json (>= 2.0.13~) pero 1.2.4-1 va a ser instalado
       Depende: node-request (>= 2.83~) pero 2.26.1-1 va a ser instalado
       Depende: node-retry (>= 0.10.1~) pero 0.6.0-1 va a ser instalado
       Depende: node-rimraf (>= 2.6.2~) pero 2.5.4-2 va a ser instalado
       Depende: node-semver (>= 5.5~) pero 5.3.0-1 va a ser instalado
       Depende: node-sha (>= 2.0.1~) pero 1.2.3-1 va a ser instalado
       Depende: node-slide (>= 1.1.6~) pero 1.1.4-1 va a ser instalado
       Depende: node-strip-ansi (>= 4.0~) pero 3.0.1-1 va a ser instalado
       Depende: node-tar (>= 4.4~) pero 2.2.1-1 va a ser instalado
       Depende: node-boxen (>= 1.2.1~) pero no va a instalarse
       Depende: node-latest-version (>= 3.0~) pero no va a instalarse
       Depende: node-which (>= 1.3~) pero 1.2.11-1 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
0

I don't think that anyone is lying :)

stretch-backports release just has a lower priority (apt-cache policy npm will show that) and You have to specify it explicitly:

sudo apt-get -t stretch-backports install npm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.