0

I have tried to pull the code from bitbucket repository. But i got the SSL certificate error unable to access 'https://bitbucket.com/scm/tcc/customer-care-portal.git/': SSL certificate problem: unable to get local issuer certificate

i have tried the following to fix the isse 1)used Git Bash to clone

git clone -b branchName clone url

2) Changed the settings in Tortoise Git to change the https to http

git config --global http.sslVerify false

3)uninstalled both Git and Tortoise Git. But the issue is still persisting

1

1 Answer 1

1

I had a very similar problem. I work under a corporate firewall.

OS: Windows 10

Problem: When attempting to use "git clone" I receive an error fatal: unable to access 'https://github.com/some-cool-thing-you-want-but-cant-have/': SSL certificate problem: unable to get local issuer certificate

Solution: Microsoft wrote a helpful post

Re iterating general instructions in case the linked post goes down and some minor differences I encountered.

  1. Navigate to the site you are trying to get things downloaded from.
  2. Following the steps in the Microsft article: Click the padlock in the browser and download the root cert. This is where I had to do something slightly different. I had chained certs, so I downloaded all of them except the deepest cert.
  3. Continue to follow the steps in the above article, switching to using a private copy of the git root cert store. My path differs for git than most because I am using git for windows 2.5.x, located under c:\program files\Git\mingw64\ssl\certs\ca-bundle.certs
  4. Then point git to use your local file as in the article git config --global http.sslCAInfo C:/Users/yourname/curl-ca-bundle.crt
  5. copy the downloaded certs into the bundle and restart your terminals or computer.

Something that hung me up for a bit was differnce between admin user and local user, setting a global config in windows will create a user based local copy and not update your cert location correctly when using git config

Super helpful for me diagnosing where my config was looking for search: git config --list --show-origin

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .