Newbie here. I'm trying to use bridged network on VM Virtualbox using VirtualBox Host-Only Ethernet Adapter. When I start the virtual program, it outputs the following error message. 'Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter' (VERR_INTNET_FLT_IF_NOT_FOUND). Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND).'

In order to debug the error, I've ticked off and re-ticked VirtualBox NDIS6 Bridged Networking Driver box on network adapter setting from the control panel. I've also removed the VM Virtual box and reinstalled the most recent one (6.0.4). Finally, I've added the VirtualBox Host-Only Ethernet Adapter on Host network manager setting on VM Virtual box. But nothing really fixed the error, and I'm stuck for hours now. Can anyone help me out from this endless pit?

  • Bridged and host-only are mutually exclusive. Do you want bridged or host-only? Commented Apr 5, 2019 at 8:41
  • I want host-only.
    – Taki
    Commented Apr 5, 2019 at 8:42
  • 1
    Then you must not select "bridged" Commented Apr 5, 2019 at 9:02
  • There might have been some misunderstanding between us. I could successfully use bridge option on "VirtualBox Host-Only Ethernet Adapter" shown on VM Virtualbox network setting. I don't know whether this issue is necessarily related to choosing between bridged or host-only since I think I'm using bridged in this case. Correct me if I'm wrong.
    – Taki
    Commented Apr 6, 2019 at 11:42

2 Answers 2


Host-Only Ethernet not working seems to be a common failure with recent Windows 10 updates.

Toggling VirtualBox NDIS6 Bridged Networking Driver off then back on in the adapter's properties is a good start, but it seems that we also have to disable and reenable the entire Host-Only adapter.

That worked for me with VirtualBox 6.0.10 on Windows 10 Update 1809.

Ref: https://www.virtualbox.org/ticket/14832

  • I just got this problem after a Windows update. This fix worked for me, thanks!
    – aimfeld
    Commented Jul 28, 2020 at 9:36
  • Oh man, that was it. +1. By the way I got this same problem-solution for Oracle VM VirtualBox 6.1.16.
    – evl183
    Commented Nov 23, 2020 at 19:59
  • The trick still works with VB 6.1.46 and Genymotion 3.2.1 on Windows 10 21H1. I had a bunch Virtual Host-Only Ethernet Adapters, but toggling the driver (close the dialog btween disabling and enabling) and disabling/enabling the main Ethernet adapter (VirtualBox Host-only Ethernet Adapter #?) has finally solved the issue.
    – AntonK
    Commented Jun 2 at 11:52

2021 Update.

  • Press Windows key
  • Type "View Network connections"
  • Open the link
  • Find the adapter
  • Right-click adapter->Properties.
  • Disable the NDIS6 virtualbox by unticking.
  • Apply & Close the dialog.
  • Right-click adapter->disable.
  • Right-click adapter->Properties.
  • Enable the NDIS6 virtualbox by ticking.
  • Apply & Close the dialog.
  • Right-click adapter->enable.

After this Docker toolbox works again. Sadly, this is also required for every vagrant box started this process needs to be repeated...

Hard to believe this bug was first reported back in 2015 https://www.virtualbox.org/ticket/14040

  • In 2021... Wow! Thanks for sharing. Great tip, saved my day.
    – Cyril
    Commented Dec 13, 2021 at 6:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .