5

Yesterday I secured my VPS (Ubuntu 18.04) with two-factor authentication (Google Authenticator). I used this tutorial to achieve this. When I tried to login to my VPS with SSH (I'm using PuTTY), it asked my password and verification code, so everything has worked perfectly.

Today I was trying to upload some files to my VPS (I have an FTP server on my VPS) with FileZilla and I got this error:

Server sent an additional login prompt. You need to use the interactive login type.

I switched the Logon Type to Interactive, but then FileZilla asked my password and verification code for every file. This was not really helpful, so I switched to Ask for password but nothing has changed. I have to enter my password and verification code for every upload.

I've tried to set the Transfer Mode to Active (with Timeout set to 0) as mentioned in this question, but unfortunately no luck with that either.

I've also tried to use WinSCP, and suprisingly there was no problem with this. I've entered my password and verification code once and WinSCP didn't ask me again. But I would stick with FileZilla if possible.

0

2 Answers 2

3

As mentioned in this FileZilla forum topic the solution is to set Maximum number of connections to 1 in Transfer Settings (File > Site Manager > Transfer Settings).

1

We get this error even if remote FTP server prompt to reset password, it's strange that FileZilla doesn't prompt to change password. I tried WINScp, changed password and all worked fine even in FileZilla post password reset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .