1

So, I have been trying to get a Windows 7 and 8 designed app to work in Windows 10, but it seemed like there was no way. Up until today, that was, when I upgraded a PC with Windows 8 to Windows 10: that app was installed on the machine when running Windows 8 and I expected it to crash after the update – it didn't, rather it worked flawlessly. That app is a Windows Vista Sidebar port for Windows 7 and 8 x64 only, with no bloat. It was the most similar program to the original I could find on the Internet at some point, and still seems to be.

Why does this app work after an update and how can I get it working on a fresh Windows 10 installation, with no OS upgrades in the process?

Here is the installer, if needed: Windows Sidebar Installer: "setup-x64.exe"

ERROR:
Windows Sidebar window

EDIT: The error seems to be caused by oleaut32.dll. I tried replacing mine in System32 with the one in the PC where I did the upgrade, but the program is still crashing.

Event Viewer report:

Log Name:

Application Source:

Application Error Date: 07.04.2019 22:51:22

Event ID: 1000

Task Category: (100)

Level: Error

Keywords: Classic

User: N/A

Computer: Alexa-PC

Description: Nume aplicație cu defecte: sidebar.exe,

versiune: 6.0.6001.16510, marcaj temporal: 0x4625ae7c

Nume modul cu defecte: OLEAUT32.dll, versiune: 10.0.14393.0, marcaj temporal: 0x57899944

Cod excepție: 0xc0000005

Deplasare defect: 0x0000000000002255

ID proces defect: 0x8f0

Oră de început aplicație cu defecte: 0x01d4ed7b46a74e6c

Cale aplicație cu defecte: C:\Program Files\Windows Sidebar\sidebar.exe

Cale modul cu defecte:

C:\WINDOWS\System32\OLEAUT32.dll

ID raport: 3b407c5a-f6eb-4909-82c8-9ed0e86f9861

Event Xml:

<Event> xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

<System>

   <Provider Name="Application Error" />

   <EventID Qualifiers="0">1000</EventID>

   <Level>2</Level>

   <Task>100</Task>

   <Keywords>0x80000000000000</Keywords>

   <TimeCreated SystemTime="2019-04-07T19:51:22.516406500Z" />

   <EventRecordID>1161</EventRecordID>

   <Channel>Application</Channel>

   <Computer>Alexa-PC</Computer>

   <Security /> </System> <EventData>

   <Data>sidebar.exe</Data>

   <Data>6.0.6001.16510</Data>

   <Data>4625ae7c</Data>

   <Data>OLEAUT32.dll</Data>

   <Data>10.0.14393.0</Data>

   <Data>57899944</Data>

   <Data>c0000005</Data>

   <Data>0000000000002255</Data>

   <Data>8f0</Data>

   <Data>01d4ed7b46a74e6c</Data>

   <Data>C:\Program Files\Windows Sidebar\sidebar.exe</Data>

   <Data>C:\WINDOWS\System32\OLEAUT32.dll</Data>

   <Data>3b407c5a-f6eb-4909-82c8-9ed0e86f9861</Data>

   <Data>

   </Data>

   <Data>

   </Data> </EventData> </Event>

  • 1
    I was able to run it on my Windows 10 VM without a problem. – Ramhound Apr 7 '19 at 17:52
  • Edited OP, to see what error I get. – antoniu200 Apr 7 '19 at 18:03
  • Just checked on another PC with fresh Windows 10 installation. It works fine there too. Also, what I notice on my PC is a small 580 KB oleaut32.dll file in WinSxS and another one of 745 KB, the last one corresponding with the size of the one found in System 32. Also, the Calendar gadget is working on my PC, but no other one. – antoniu200 Apr 7 '19 at 20:10
2

The solution seems to be as follows: the Windows Sidebar in Windows Vista has code in the Registry. The executable needs to be registered using the command sidebar.exe /regserver after adding the registry keys for the Windows Sidebar. After that, all the gadgets will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.