I am copying files from Snow Leopard to a mounted ext4 share via Samba, that's on a Fedora machine. Some files cannot be copied, and give this error:

The operation can’t be completed because you don’t have permission to access some of the items.

I've noticed that the files that can't be copied have an @ at the end of their permissions whien I do 'ls -l' in the command line. For example, I can copy the second file but not the first:

-rwxrwxrwx@  1 miles  staff     1448 May 14 22:55 test.txt
-rw-r--r--   1 miles  staff     136 Apr  5 17:06 image.psd.zip

From what I've found, the @ means the file has 'additional properties'. Does anyone know how I can resolve this issue so I can copy the files to the fileshare??


UPDATE: It sounds like i need to mount the ext4 drive using 'user_xattr' (see mjmwired.net/kernel/Documentation/filesystems/…). But I haven't figured out how to do that. I see where it's mounted, in /etc/fstab:

/dev/fedora-raid/FedoraRaid  /media/share  ext4  defaults  1 2  

I changed it to:

/dev/fedora-raid/FedoraRaid  /media/share  ext4  defaults, user_attr,acl  1 2  

but then the share didn't mount at all

How do I make that use 'user_attr'?

  • The fstab entry you list here has a space after defaults,. That could definitely cause some trouble. – oKtosiTe Jan 11 '11 at 11:28

I had the same problem ("useradd" copies skel files from root (ext3) to home (ext4) partition with this error).

Mounting ext4 with option "acl" solved the problem.


I'm assuming you don't need these extended attributes.

Try to use cp without copying the extended attributes.

cp --no-preserve=xattr source

Do not preserve the specified attributes. The attribute_list has the same form as for --preserve.

Or mount with nouser_xattr option editing your fstab (backup your original /etc/fstab file). Check it's structure to avoid problems. If needed, check fstab man page for more information.

/dev/fedora-raid/FedoraRaid /media/share ext4 defaults,nouser_xattr 1 2

Beware of spaces in fstab, the options in this file are separated by spaces, so if you use one in your fourth column for example is not going to work. If your directory does have a space in it, use this solution.

  • I'll try it, but I don't want to be restricted to only copying files from the command-line. See my 'update' in the original post. – 99miles May 18 '10 at 0:27
  • thanks, but it isn't working ;( – 99miles May 18 '10 at 1:23
  • Both solutions (cp in cmd and mount)? Unfortunately I don't have a setup like yours to help in your problem... – GmonC May 18 '10 at 1:48
  • In Finder I got the same error as before. On command line with your suggestion I got cp -no-preserve=xattr /screenshot.jpg /Volumes/share/files/ cp: illegal option -- o usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_directory – 99miles May 18 '10 at 1:59
  • I setup VSFTP and I can copy the files over through that. So, that's a reasonable workaround, but I'd still love to be able to copy via Finder. – 99miles May 18 '10 at 2:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.