0

My cursor keeps moving on its own (heading to the top right corner slowly), it has been happening for like 5 months now.

I have tried disconnecting my USB mouse, disabling my touchpad and nothing worked. I tried restarting the computer which would only successfully fix the problem for a very short while (10 minutes) and then it is back to its annoying self. I highly doubt that it is a hardware issue since the same mouse works fine on other computers, and I have tried multiple other mouses and they all had the same problem. Restarting the computer while the touchpad is disabled produced the same results. I am guessing it is an OS issue but I have tried updating the OS and it also did not work. I have no idea what to do to fix it.

Hardware & Software I am using:

  • Lenovo Thinkpad T480.
  • Fedora 29.
  • Microsoft USB mouse.
  • Gnome version 3.30.2.
0

I see that your model has the "wonderful" eraser head mouse controller in the middle of the keyboard. This is a semi-analog device which reads pressure and converts it to mouse movement. It is also called a Pointing Stick, although Lenovo apparently calls it the Track Point or TrackPoint.

In mouse settings of the control panel, you should be able to independently disable the Track Point and Touch Pad. If either one is disabled, you may be able to determine the problem more effectively.

It's unlikely that the Touch Pad is the problem, based on your description.

  • Oh my God! I have never used this Track Point thing or saw the point of it, so I forgot all about it, since I am using Fedora I disabled it using this tutorial and I no longer have the problem. Thank you very much. [forums.fedoraforum.org/… – Donatello Apr 9 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.