0

everyone, My machine is ubuntu16.04 I got 2 Tesla P100 , Firstly,I install nvidia-driver 418, the result is good. Then Then I install cuda9.2(The reason why I didn't choose cuda10.0 is that I want to use pytorch0.4 but it doesn't support cuda10.0). I got this:

nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2018 NVIDIA Corporation
Built on Tue_Jun_12_23:07:04_CDT_2018
Cuda compilation tools, release 9.2, V9.2.148

nvidia-smi

But when I check ,

cd /usr/local/cuda-9.2/samples/1_Utilities/deviceQuery
sudo make
./deviceQuery

it gave me ->CUDA driver version is insufficient for CUDA runtime version.


I installed nvidia-driver by

sudo apt-get install nvidia-418

And I installed cuda by download the cuda_9.2.148_396.37_linux and use sudo sh cuda_9.2.148_396.37_linux,(without installing the driver and I have set the relevant PATH).

Can anyone help me ? (After I installed the driver418, I installed the cuda9.0 firstly,but it didn't work because the same reason.Then I uninstalled it and tried the cuda9.2,) Beg your help!

0

Many months late, but in order to help people out. For CUDA to work, you have to keep your eGPU plugged in while running CUDA. If it still doesn't work, check that your driver(NVIDIA drivers, not CUDA) are up to date/highest for your OS. If it doesn't work, it means that your GPU is not supported in your current OS. For example, in macOS you can only use up to the Geforce GTX 10 series.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.