I have Windows 7 Ultimate 32bit installed on a Dell Latitude XT Tablet and for the life of me I can't figure out this really weird problem.

The symptom is that the Wireless will disconnect from the AP and if I tell it to scan again, it says there are no APs in the area. I do have another wireless card in the laptop and if I disable the first one and enable the second, I am able to get onto the wireless however if I want to use the first card again I have to restart. I tried enabling/disabling the device, nothing will kick start the wireless again in the first card without a restart. I even tried different drivers. So, it seems it is random but it does occur more often when there is increased network activity (ie downloading a large file). The laptop doesn't seem to be overheating.

I have tried the following: Under "Change Advanced Power Settings" for the current power profile, I set the "Wireless Adapter settings" to "Maximum Performance". Under device manger, I went to the card in question, and went to the advanced tab and set the "Power Saving mode" to "MAX_PSP"

Both cards I have seem to exhibit the behavior after awhile. Both models of those cards are: Dell Wireless 1505 Draft 802.11n WLAN Mini-Card
Gigabyte GN-WS30N 802.11n mini WLAN Card

Has anyone have any ideas or ran into this before?

3 Answers 3


Don't kill me for being captain obvious.

Did you try upgrading your drivers to the very latest ? Upgrading router's firmware? Check for a wireless utility ? (Like Intel's wireless utility outperforms Windows's one and it provides much better connection stability, at least for me on a Toshiba laptop. On my Lenovo I use the Lenovo CM one.)


I also feel the need to be sure: is the Dell Latitude XT officially supported in Windows 7?

I only ask because my laptop, the Dell Latitude D620, is technically not supposed to support Windows 7, according to Dell. As a result, I have actually had to REVERT my drivers to OLDER Vista ones, rather than updating to the newest drivers, as my graphics drivers (nVidia) corrupt the machine when updated to the newest.

May or may not apply--I couldn't find whether the XT was supported or not, but it's something to consider. Good luck to you.


Do you have a 5 GHZ frequency capable router? If so, please try to go into your router configuration and give the 5 GHZ signal a different SSID name than the 2.4 GHZ signal.

Your issue sounds like something I experienced.

In the end, the problem was related to my laptop trying to connect to the 5 GHZ signal even if the laptop was not very close to the router (5 GHZ only works really well if you're located close to the router).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .