3

I've been tearing my hair out trying to connect to an SMB share and I keep getting "Unexpected Network Error" and "Error 0x80004005". I've tried enabling SMBv1 in Windows Features, and I've tried ensuring that sharing is enabled on the network. It is a Linux-based NAS server that is kinda old but I don't have the details on it. I can connect to it via my MBP (macOS Mojave), so this is confusing me.

Does anyone know how I can connect to this server?

4

So the solution to my particular case required a modification to the registry, but a relatively easy and benign change that is easily reversible.

Open regedit.exe and go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and do the following:

Warning: You should take a backup of the entire registry, or at least take a screenshot of this page to ensure you can revert any changes.

  • Change RequireSecuritySignature from 0 to 1. That isn't a typo; I know, this is really counter-intuitive, but it worked.

Other systems in our org needed these changes:

  • Change AllowInsecureGuestAuth from 0 to 1.
  • Add RequireSecureNegotiate and set it to 0 (DWORD).

Then everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.