13

I have a HiDPI screen so running DOSBox normally gives almost unreadably small text. How can I scale the DOSBox window by a fixed and integer scale factor, say 200% that works for all resolutions?

  • None of the HiDPI Compatibility settings in Windows has any effect on DOSBox.
  • Setting windowresolution to something is not gonna fly, because it scales all resolutions to match the 'height' of that setting, giving crappy results. I care mostly about x200, x400 and x480 resolutions, and the least common multiple is x2400 which doesn't fit my monitor.

4 Answers 4

15

Try this advice:

  • go to dosbox installation directory (on my machine that is C:\Program Files (x86)\DOSBox-0.74 ) as you see the version number is part of the installation directory name.

  • run "DOSBox 0.74 Options.bat"

  • the script starts notepad with configuration file: here change

    windowresolution=1600x800
    
    output=ddraw
    

(the resolution can't be changed if output=surface - that's the default).

  • safe configuration file changes.

You might also need to ensure that the fullresolution parameter specifies the true resolution of the monitor.

If this doesn't help, please add to the post the contents of the configuration file.

You could also try with ddraw to use the scaler parameter, with normal3x as the scaler to multiply by 3. The scaler is applied first, so for example a 320x240 game becomes 960x720.

scaler=normal3x forced 
6
  • Did you even read my second bullet point? Apr 15, 2019 at 10:24
  • There are two settings that might be important here. Perhaps detailing what you tried, and posting the contents of your configuration file, could make the question clearer.
    – harrymc
    Apr 15, 2019 at 10:38
  • I already experimented with windowresolution. It sets a fixed window height. The setting for output doesn't change this formula except for surface which disables it. Apr 15, 2019 at 13:29
  • I added one more setting to my answer that you could try with or without windowresolution. Best value for windowresolution is a multiple of the original game resolution. If this was for example 640x400 then try for 1280x800. The default output of "surface" doesn't allow scaling, so use something else, maybe "opengl", but other possibilities are "ddraw" or "openglnb" or possibly "overlay", so you will have to experiment. Unfortunately DOSBox fonts are only scalable with pixelisation. You will need to experiment.
    – harrymc
    Apr 15, 2019 at 14:17
  • Perfect. scaler=xx forced was what I was looking for. Apr 21, 2019 at 10:42
4

For anyone using dosbox in Linux Ubuntu, this video worked for me!: https://www.youtube.com/watch?v=7klX3U3UjlI

Open ~/.dosbox/dosbox-0.74.conf (or whatever version number appears in that filename) and change these settings to:

fullresolution=1024x768
windowresolution=1024x768
output=opengl
1

I had this issue after installing Dungeon Keeper via EA Games on my Surface. The solution is much as that one stated by harrymc, though the files are in a different location and I couldn't run the batch file to edit the parameters.

Instead:

  • Navigate to Program Files / EA Games / Dungeon Keeper / DATA

  • Change permissions (via right click / security) on the DOSBox folder so that local admin / users could make changes

  • Navigate to DOSBox folder

  • Right click / open with on 'dosbox.conf'

  • Make changes listed in the earlier solution and save them

I hope this helps some people. It's just useful to know that DOSBox could be anywhere (or multiple anywheres!) if you're installing it alongside another package, and that permissions may also be an issue.

0

Configuring this sort of thing is made a lot simpler by using D-Fend Reloaded, which includes DOSBox out of the, er, box. It gives you a GUI for managing all these settings.

What @harrymc said was helpful for my case, and can be applied in the game profile editor.

Just right-click the game and choose "Edit...", then in the dialog simply apply the settings you want. In my case, I wanted to scale up Empire Deluxe from its default 800x600 to 1600x1200, so I changed the following under "Graphics":

enter image description here

This will essentially update the config files under the hood for you, with less of a chance of stuffing it up accidentally or it not working due to a typo, etc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .