1

While trying to install GTK with vcpkg it fails to extract libexpat-libexpat-R_2_2_6.tar.gz:

Building package expat[core]:x64-windows...
-- Downloading https://github.com/libexpat/libexpat/archive/R_2_2_6.tar.gz...
-- Extracting source C:/Users/USER/git/vcpkg/downloads/libexpat-libexpat-R_2_2_6.tar.gz
CMake Error at scripts/cmake/vcpkg_execute_required_process.cmake:56 (message):
    Command failed: C:/Program Files/CMake/bin/cmake.exe;-E;tar;xjf;C:/Users/USER/git/vcpkg/downloads/libexpat-libexpat-R_2_2_6.tar.gz
    Working Directory: C:/Users/USER/git/vcpkg/buildtrees/expat/src/TEMP
    Error code: 1
    See logs for more information:
      C:\Users\USER\git\vcpkg\buildtrees\expat\extract-err.log

extract-err.log:

CMake Error: Problem with archive_write_header(): Can't create ''
CMake Error: Current file: libexpat-R_2_2_6/README.md
CMake Error: Problem extracting tar: C:/Users/USER/git/vcpkg/downloads/libexpat-libexpat-R_2_2_6.tar.gz

And running tar manually results in:

> tar xjf C:/Users/USER/git/vcpkg/downloads/libexpat-libexpat-R_2_2_6.tar.gz
libexpat-R_2_2_6/README.md: Can't create '\\\\?\\C:\\Users\\USER\\git\\vcpkg\\buildtrees\\expat\\src\\TEMP\\libexpat-R_2_2_6\\README.md'
tar: Error exit delayed from previous errors.

Versions:

  • Microsoft Windows [Version 10.0.17763.437]
  • cmake version 3.14.2
  • bsdtar 3.3.2 - libarchive 3.3.2 zlib/1.2.5.f-ipp
  • vcpkg 2018.11.23-nohash (commit 0907798)

Edit:

The tar error is expected, the issue manifests in cmake where the expected output (see extract-err.log) should be:

cmake -E tar: warning: skipping symbolic link "libexpat-R_2_2_6/README.md" -> "expat/README.md".

Edit:

Looks like this is an active cmake issue https://gitlab.kitware.com/cmake/cmake/issues/19102

  • 1
    Have you tried running as Administrator? – DavidPostill Apr 14 '19 at 18:37
  • @DavidPostill yes, same error – Ian678 Apr 14 '19 at 20:46
1

Alexej Harm found the setting that causes this issue https://gitlab.kitware.com/cmake/cmake/issues/19102#note_558431.

The UTF-8 beta in intl.cpl > Administrative > Change system locale... needs to be unticked for cmake (3.14.2) to function properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.