-1

I just set up a new server (OpenSuse Leap 15.0) and installed the Check_MK-Agent. Every time my Check_MK-Servers polls this agent, this socket-access ist logged:

Apr 14 20:05:26 static systemd[1]: Started Check_MK (xx.xx.xx.xx:xxxx).

As this happens every minute, my log-file is spammed with worthless information.

I already have two linux-machines monitored by my Check_MK-Server and none of them has these log-entrys. All three machines have syslogd running and I already invested hours in comparing the installations and conf-files without luck.

Does anybody know how to prevent syslogd from logging socket-calls?!

closed as off-topic by Mokubai Apr 15 at 6:59

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm voting to close this question because it has been cross posted to unix.stackexchange.com/questions/512446/… – Mokubai Apr 15 at 6:59
  • @Mokubai Wouldn't it usually be better to migrate the question so that one could be closed as a duplicate of the other? – grawity Apr 15 at 9:48
  • @grawity potentially yes, but it could leave a long period where the other site has two identical questions with identical answers and no one voting to close. If the question is closed there for having an answered duplicate here then I'm happy to reopen here. – Mokubai Apr 15 at 10:28
0

systemd and syslogd do not log socket calls.

The Check_MK-agent is an "inetd service" – this means it does not run persistently and does not create its own listener socket; instead it relies on a "superserver" to do this job. Every new connection is accepted by the superserver, which then starts a new copy of Check_MK to handle that particular connection.

Traditionally the inetd or xinetd superserver programs are used for this purpose. Your newly installed system however uses the "socket activation" feature of systemd to achieve the same thing – in this system, the listener socket is represented by a .socket unit and each new instance is represented by a new au­to­mat­i­cal­ly generated .service unit.

So the log message is not about socket access at all – it literally says that a service has been started. There is no option to disable service startup logging.

To get rid of this message, deactivate the systemd .socket unit and reconfigure your Check_MK-agent to be started via xinetd (or traditional inetd, or any other alternative).

  • Yes!! It seems that the Opensuse-Leap-15.0-installer installs the xinetd by default when using the "system role desktop". But it does not so when using the "system role server". I did a "systemctl stop check_mk.socket", installed xinetd and after "systemctl start xinetd" eveything ist fine now! Many thanks! – Rowham Apr 15 at 8:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.