0

Prior to Windows 10 the Taskmanager (taskmgr.exe) was automatically started with priority "higher" - which totally makes sense if you want to kill an application that runs amok (and that usually has the CPU priority "default").

However since Windows 10 the Taskmanager is started by default with the priority "Low" instead of "High" which makes it useless in case the CPU is utilized at 100% by several threads.

How can I restore the default behavior of the older Windows versions and always run taskmgr.exe with a priority higher than default?

Note that scripts or batch files are of no use to me as in a high CPU load scenario it is even difficult to execute Ctrl+Alt+Del and then select the Taskmanager. Starting a script is not on option in such a scenario!

  • Just to add a quick tip, if you utilize the keyboard shortcut Ctrl+Alt+Esc it will open Task Manager directly. – Run5k Apr 15 at 15:10
  • @Run5k yes, but it then runs with priority low which means it is getting next to no CPU time in case all cores are used up to 100%. Then one click can take several minutes before Taskmgr reacts to it. – Robert Apr 15 at 15:28
  • Understood regarding the CPU priority. I was simply trying to pass along something that would save you an extra step, since the narrative within your original post made it sound like you were unaware of it. – Run5k Apr 15 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.