I'm trying to install Visual Studio 2010 on Windows 7 64-bit and I keep getting following screen:

Error occurred during setup - Setup could not install the following component: Microsoft Visual Studio 2010 Express Prerequisites x64 etc.

I tried to install also Visual Studio 2008 with similar result. I'm starting to think it might be caused by some problems with my Windows Installer. Any idea what could it be?

  • 1
    Is your Windows 7 a 64-bit edition? – Ƭᴇcʜιᴇ007 May 18 '10 at 18:24
  • Yes, it is. Will edit the question. – Ondrej Slinták May 18 '10 at 18:25
  • Are there any errors in the event viewer? – Glennular May 18 '10 at 19:04
  • There's following error: Product: Microsoft Visual C# 2010 Express - ENU -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2329. The arguments are: 32, C:\Config.Msi\ad9b7d.rbf, – Ondrej Slinták May 18 '10 at 19:28
  • Have you tried using Microsoft's Log Collection Tool – heavyd May 21 '10 at 15:00

We had same problem. And we found the reason. The .iso we downloaded from MS site was downloaded with errors.

We downloaded it again with different downloading tool. New .iso installed correctly. And these .iso files appeared to have different checksums.

The info you got from log seems to confirm my thoughts: The installer has encountered an unexpected error installing this package. This may indicate a problem with this package.

Try to download the VS2010 .iso image again.

  • This is a right answer. Unfortunately, I couldn't check it sooner, so I cannot mark it as correct anymore :( – Ondrej Slinták May 30 '10 at 8:27
  • I'm happy enough. :) Have a good coding. – Vasyl Boroviak May 30 '10 at 11:26

Going off your error code of 2329, and googling it with "visual studio 2010", I get the following link:

and looking up that error code:

2329 Error deleting file: 3. GetLastError: 2.

Another link says to uninstall Windows Installer, reboot, and reinstall it.

  1. Control Panel > Programs > Uninstall windows installer
  2. Reboot
  3. Download and install it:

Link to Windows Installer 4.5:

  • Yep, found those too. I cannot find this "Uninstall windows installer" anywhere. I also tried to download and install all of the files from Windows Installer link you've provided, but none of them seem to work on Win7. Afaik, Win7 uses Windows Installer 5, which I cannot find anywhere for download. – Ondrej Slinták May 18 '10 at 20:48
  • What version of Windows 7 are you using? And, did you install/upgrade Win7 yourself, or is this from an OEM (Dell, HP, Lenovo, etc)? – spong May 18 '10 at 21:32
  • I had originally Win Vista Ultimate, which I upgraded to Win7 Ultimate. All done by myself. – Ondrej Slinták May 19 '10 at 5:49
  • Have you had trouble installing any other programs besides VS2010/VS2008? I've upgraded my PC from Vista Ult to Win7 Ult 64-bit without a hitch, but I did a fresh install, not an upgrade. I do some development on it too with VS2008/VS2010. When it's something as important as a new OS, I always do fresh install over upgrade. – spong May 19 '10 at 14:35
  • I hadn't problems with anything until now. I even had installed VS2008 before, uninstalled it and when I tried to install VS2010, this happened. Only other weird thing that keeps happening from this point is crashing of AdAware, but don't know if it has something to do with it. – Ondrej Slinták May 20 '10 at 10:36

If you are using a home brew disk that you created from an ISO file, then redo it. It took me three times to create an install disk before I could finally install it without errors. Unfortunately, there is no indication that the burned disk had errors or problems other then not installing.

protected by Community Jul 19 '11 at 16:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.